Nvsipl_camera: ERROR: NvSIPLCamera Init failed

Please provide the following info (tick the boxes after creating this topic):
Software Version
DRIVE OS 6.0.6
DRIVE OS 6.0.5
DRIVE OS 6.0.4 (rev. 1)

Target Operating System

Hardware Platform
DRIVE AGX Orin Developer Kit (940-63710-0010-D00)
DRIVE AGX Orin Developer Kit (940-63710-0010-C00)
DRIVE AGX Orin Developer Kit (not sure its number)

SDK Manager Version

Host Machine Version
native Ubuntu Linux 20.04 Host installed with SDK Manager
native Ubuntu Linux 20.04 Host installed with DRIVE OS Docker Containers
native Ubuntu Linux 18.04 Host installed with DRIVE OS Docker Containers

Hi Nvidia, I am trying to bring up the camera device from valeo on drive AGX orin hardware. I see the below error log . I enabled the verbosity to level 4 to capture more logs attached here.

sudo ./nvsipl_camera --platform-config “V1SIM728S2RU2030NB20_CPHY_x4” --link-enable-masks “0x1111 0x0000 0x0000 0x0000” --showfps -d 1

nvsipl_camera: ERROR: NvSIPLCamera Init failed

nvsipl_camera: ERROR: Master initialization failed. status: 10

nvsipl_camera: ERROR: GetSyncObj failed. status: 10

nvsipl_camera: ERROR: Compositor: UnregisterNvSciSyncObjs failed

can you please let me know how we can debug this issue. This is the first time we are trying to bring the camera on AGX orin.
nvsipl_4_cam_port_a0_a3.txt (79.7 KB)

Please note that camera bring-up is not supported through the forum. It is recommended to discuss any custom camera module request with your NVIDIA representative first.

You can find a list of supported Valeo camera modules on DRIVE Ecosystem - Hardware and Software | NVIDIA Developer. Additionally, for a comprehensive list of other supported camera modules, please refer to this page DRIVE AGX Orin Sensors & Accessories | NVIDIA Developer.

Hi VIck,

This is not a custom camera module , this is Valeo IMX728 camera supported on Orin . May be my sentences are misleading earlier. what i am itrying to convey is trying to load the driver and test using nvsipl. This version B of the camera is already in your support list.

Please specify the Valeo camera module name you’re using so I can check it with our team.

Have you tried with a single link to the camera group?

The part name is “Camera Narrow IMX728 30 FOV”. I am not sure if there is any other name, Yes i tried with single camera alone as well

Could you please share the image of the module? Additionally, if there is a part number associated with it, kindly provide that information. Furthermore, do you have any reference to a Valeo page or documentation related to the module? Thanks.

Vick, here is the part number : 3105615. I do not have any reference to Valeo page. I will try to check with Valeo on this front.

In How to set up multiple cameras of different models - #9 by TomFord, the developer was able to run the sample app with “V1SIM728S2RU2030NB20_CPHY_x4” configuration on 6.0.6. However, I don’t know if you’re using the same camera module with him.

Please refer to To run the sample applications and wfdCreateDevice failed on drive agx orin - #15 by VickNV. Thanks.

Hi Vick,

One question , how can we know the platform-config for the camera models we have. I did not have that information from Valeo. Is there a way i can find from nvidia documentation . I want to check what should be the right config used for 3105615-1 or for 3105649-1 .


I believe the module you are using should have a part number prefixed with V1SIM728S2RU. Once you confirm the part number with Valeo, you can check it in the output of ‘nvsipl_camera -h’.

Has the original issue been resolved?

Hi Vick , thanks for checking back but am still waiting back to hear from Valeo for the correct part number .

I think the “V1SIM728S2RU2030NB20_CPHY_x4” configuration should work with your camera module. Please go ahead and execute the following command:

$ sudo /opt/nvidia/drive-linux/samples/nvmedia/nvsipl/test/camera/nvsipl_camera --platform-config 'V1SIM728S2RU2030NB20_CPHY_x4' --link-enable-masks '0x0001 0x0000 0x0000 0x0000' --showfps

1 Like

Vick , is it possible to take this into private discussion , this thread with you ?

The issue was clarified with private discussion.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.