NX boot failed

Hi, Expert

NX boot failed. Attached is log, please help to check.
We will mass produce immediately, and we are worried.BTW, Jetpack is 4.4[L4T 32.4.3] and We haven’t made any change to bootloader code. The bad possibility is 2/50.

We did some work.Cross-validation proves the SD card is OK. Use a multimeter to measure the power supply 12V of the NX board and the voltage on the board are normal. So we think the problem is on the core board.
SaveWindows2021_6_8_15-19-16.TXT.txt (20.2 KB)


It looks like you are booting from USB and sometimes USB cannot get detected. Is this your usecase?

[0005.158] E> Failed to initialize device 5-0
[0005.162] E> USB boot failed, err: 2088502034
[0005.166] I> ########## Fixed storage boot ##########
[0005.171] E> Blockdev open: exit error
[0005.175] E> kernel boot failed

Hi Wayne. Actually we boot from SD not USB. And we are told that NX can’t boot from USB.

Are you using jetson devkit or your own custom board?

The result shows even the sdcard is not detected so the cboot goes to check the usb boot.

[0003.949] I> ########## SD boot ##########
[0003.953] I> No sdcard
[0003.955] I> -0 params source =
[0003.959] E> Blockdev open: exit error
[0003.962] E> SD boot failed, err: 724238353

But we inserted the SD card. And we inserted the SD into another board, and it worked. So the SD is OK.
How can we know why the SD is not detected suddenly? Because it has been working well for one month.

Please directly reply my question.

Are you using jetson devkit or your own custom board?

We use jetson devkit.

Please check if only one board has this issue. If it is, then please RMA this board.

If many boards have such issue, please try different sdcard and test again.

We have two boards that cannot be activated. One of them couldn’t be started as soon as we received it. We sent it to the agent, and the agent used the SDK manager to flash, and it worked.
They also proposed that as long as it can be activated when shipped, then in theory, this will not happen when used later. But now another board(which is above) cannot be started after using it for a month.
We hope that we can find the root cause and know how to avoid this situation. Because we will mass production on June 18. We think this is a big risk. We don’t know if it is too late to RMA this board. Can you analyze based on the above log?

I think the real question here is why do you use a devkit for “mass production”? Devkit means the NV developer kit. Otherwise it would be a custom board.

OK, forget the “mass production”. By swapping the core board on different carrier board, it is determined that the core board is faulty. Now we want to know what caused it.

Ok, then another new question here.

What kind of module are you using? The module we provide for customer to do production is the emmc based module.

Thus, I want to know what “boot from sdcard” are you using here.

We are using this kind of development kit in the picture


If you have a sdcard slot on your module, then it is not a production module. We don’t support such module on custom board.