NX DevKit does not boot up

Devkit is not booting up. No LED, output on the screen or serial. I had a power outage and the devkit hasn’t booted up since. The devkit is connected to a power bar with surge protector, so I know it wasn’t a power surge.
Any thoughts?

I see you have a flash thread as well, but it is worth mentioning here something regarding surges…

The surge suppressor is a very good idea, and helps to prevent electrical damage. However, if the filesystem is being written to at the moment when power is lost (or if writes are cached but not yet written), then you can still get software corruption for the unwritten part of the SD card data. Sometimes this can be recovered from without any effort, but at other times (which you seem to have run into) it can be easier to just flash again if there is no important data to save. In the case of important data to save there are ways to clone and/or repair a partition (especially an SD card which can be plugged in to a Linux host PC instead for repairs).

I tried switching the SD card, but no luck. The issue is when I power it on, nothing happens. I do not see any out put or the power LED.

The power LED should work even if software is bad. Can you verify your power adapter is still putting out power? If so, then you might have a hardware failure (usually, if there is a power component failure, then it is on the carrier board itself, while the module typically survives).

I have to tried to reboot the DevKit or review the serial output, but no luck. There is no output from serial, no LED. Tried using both power plug and microUSB and no luck.
Any suggestions? Not sure if there is a way to start an RMA or or to validate if the power or something is messed up?
Thanks in advance!

Don’t forget that there is a jumper to change if switching between barrel connector and micro-USB power (at least on some models…not sure if mine is standard or not). Would someone here know of a test point he could measure voltage at on the carrier board to see if power is actually getting through?

FYI, the RMA FAQ is here (but might differ if you used a third party supplier):

@aidev if it is not the power source - that you could test with multi-meter or logic analyzer - then it is likely RMA issue

The 5V and 3.3V pins on the 40 pin header will do the trick but unless the green LED is actually burnt out it’s the best indicator. When you test make sure there are no other devices connected. No USB devices, monitors, cameras, and nothing connected to the 40 pin header. It’s possible that one of them is causing the power issue.