No power to Jetson

I have several Jetson Xavier Dev Kits. One of them will not power on, the cable is connected but the power led won’t light up on button press.

Swapping out the Xavier Chip with another unit shows that the problem is with the developer break-out board.

Any thoughts on why there would be no power? Is there a fuse to check? A BIOS reset?

Hi, do you mean the issue is on the carrier board not module? To locate issue, first you need to check the signals involved in power on sequence (listed in OEM DG), that might give hints on root cause.

Yes, it seems that the problem is the carrier board and not the module since swapping carrier boards allows the module to boot.

The power on sequence in the DG does show a few lines that need to be pulled high for module to boot but I can’t discern where to probe on that on the carrier board. I tried changing up the sequence by powering through usb-c and by changing the jumper to auto boot on power but neither worked.

There are carrier board specification and reference design files package in DLC. You can find the pins of signals to measure.

Can you check the input current when press power on button? If it is too much, some components might be broken.

I haven’t been able to figure out what’s wrong with the Jetson. How do I send it in for warranty support? The NVIDIA chat rep said to make a post on this forum.

Here is the link of RMA process: https://developer.nvidia.com/embedded/faq#rma-process