Omniverse back-end services not running

Howdy all! This is my first forum post so I apologize if certain parts, like links and pictures, weren’t used correctly :)

I am trying to get into using Omniverse and I’m running into a bit of trouble. As the title implies, when I’m trying to create a nucleus server to share, it keeps saying “failed to connect to the server” and other services refuse to start.

I looked in the settings and it shows 3-5 of the services stopped (it’s different almost every time I check):

As a result of this, I can’t create a nucleus server to be shared. I am essentially aiming to have a Win11 computer running windows-only applications connect to this Ubuntu computer running Linux applications through nucleus, but as shown, the nucleus server and other services have been quite unstable to make this connection.

I have tried a lot of different solutions that I have found on the forums and around the internet, but nothing is working. I have tried restarting the services, checked toml files, logs claim “address (localhost) is already in use” but nothing is using the addresses–that I know of–I have tried killing services through the terminal, I have used the cleanup tool, manually deleted a bunch of folders/files, and ultimately, reset my computer; formatted the drives and reinstalled Ubuntu, only for the problem to still be there on a completely clean install.

My system consists of:
Ubuntu 22.04.2
Intel Core i7-9700KF
RTX 3060 with 525.85.05 driver version

At this point I can only make guesses as to any potential causes to the problem:

  • Ubuntu 22.04 doesn’t work well with Omniverse, however, I haven’t seen anything that says it doesn’t
  • My Omniverse folders–the folders the launcher prompts to set paths to when first run–is on a second SSD separate from the OS. It wasn’t partitioned during the OS installation so no OS-related data is on it.
  • I installed Ubuntu using the minimalist install, so a lot of packages might be missing
  • I don’t know if networking/security has anything to do with this, in terms of firewalls, port forwarding, router/switch settings etc. but everything works fine on my Win11 computer which is on the same network–that I hope to connect to the Ubuntu nucleus server. The network consists of my Win11 and Ubuntu computers connected to each other through an ethernet switch and both are connected to a WiFi router through WiFi. I have tried a number of different network configurations in terms of IP settings, using only ethernet, using only WiFi, both off etc.

My logs for all the services have been attached (if I did it right).

Service (499.2 KB)

I hope this is enough information, but please let me know if anything else is needed!

Hello @Green_apple! I appreciate the details! I’ve sent this over to the Nucleus team for further assistance!

Hello again @Green_apple! Just wanted to give you an update. The development team believes that the issue you are experiencing is a bug the team has been tracking and working on with Ubuntu. They are taking a look at your logs to confirm.

Gotcha, thanks for the update!

Hey there, I made an account to mention that I am facing the same issue.

I am running Fedora, my colleague has no such issues on Windows. Both are the same laptop build (Intel® Core i7-12700H, Mesa Intel Graphics) so I’m assuming its Linux specific.

I’ve attached my logs, hope that helps resolve the problem somehow: (743.3 KB)