Optix7.3, GeForce driver 466.63 win64. nvoptix.dll not found

Hi,

Just getting setup with the Optix7.3 SDK on Win10. Have attempted to run optixHello.exe but it fails on optixInit() apprently because there is no nvoptix.dll on my system, despite having just installed 466.63-desktop-win10-64bit-international-whql.exe.

Is nvoptix.dll missing from 466.63-desktop-win10-64bit-international-whql?

Cheers,
Greg

Hi Greg,

I don’t think the dll is missing from the installer. I checked the contents of that installer by opening it in 7zip, and I can see the packaged version nvoptix.dl_.

Will you check your C:\Windows\System32\DriverStore folder to see if nvoptix.dll was copied in there, and maybe whether you have multiple versions? Also, dumb question, but have you rebooted since installing the new driver?


David.

Yes. I had rebooted :)

I found nvoptix.dll in C:\Windows\System32\DriverStore (thanks) and have copied it manually into C:\Windows\System32\, but now I’m getting optixInit returned OPTIX_ERROR_UNSUPPORTED_ABI_VERSION (7801). I’m on 19043.985 which is Win 10 Pro 21H1. Any suggestions?

The last time I saw that error, it was a case of an old DLL version getting picked up from previous driver installs. Do you have multiple copies of the DLL, or remnants of older drivers? Check also for nvrtum64.dll. EVGA RTX 2080Ti Black IRAY OptiX 7.1.0 error (SOLVED) - #2 by CarstenWaechter


David.

Brilliant! Thanks. I should’ve been more careful with which ‘nvoptix.dll’ I manually copied out of the DriverStore. The version of that DLL was 7.2.0, so I found the newer one in a more recent sub-folder in DriverStore and now it works. Thanks for your help sorting that out!

1 Like

Excellent! Glad you got it sorted. I think you shouldn’t need to copy the dll anywhere, that your system should be finding it in DriverStore automatically, so there might still be a little cleanup that could fix the underlying issue. I would hope you don’t need to copy any dlls after future driver installs, that should not be necessary.


David.

Interesting. Not sure if it’s relevant, but I used “Custom Install” (not “Express”) and accepted the defaults (I think). Checking the Sys Info using the NVidia Control Panel showed the old driver version after the install+reboot. So I re-installed using the Express install and rebooted and the ‘nvoptix.dll’ still wasn’t in System32, but the Sys Info showed the correct driver version.

That makes sense, and maybe there is some kind of problem with the custom install. Normally, you shouldn’t have a copy of nvoptix.dll directly in the C:\Windows\System32\ folder, but there should be one somewhere under the DriverStore sub-folder.

This might be some kind of conflict with either older driver styles or older OptiX distribution, but if you can get it working with the express install process without having to manually copy any DLLs, that sounds workable.


David.