Paint brush doesnt work on my landscape, but it works on my meshes

Edit: I fixed it by turning my landscape in UE into a landscape streaming proxy and then exporting that proxy over to a USD and into USD Composer. Please let me know if there is a better workflow for this, but for now this will do!


My project was originally created in UE 4, but I am now trying to port everything over to USD to take advantage of all the benefits that comes with it. Ive exported everything onto a nucleus servers successfully and gotten everything into USD composer.

However, I am not able to use the paint tool to add foliage like trees, bushes and grass to my landscape. I have made sure “All meshes” are selected, but the tool just does not work on my landscape, but it does work on all of my other assets like buildings etc. however I obviously doesnt want my trees on my buildings!

If I had to guess, the issues is because the landscape was created in UE 4 using the landscape tool they got over there, so it is a little bit different than all the other static meshes which has always been static meshes. Perhaps the workflow to exporting over landscapes from UE is different (I just right clicked on my landscape and did “export to Omniverse” like with everything else!) or perhaps there are something ive got to do in USD composer to allow me to use the paint tool on it. As mentioned before, I made sure to select “All meshes” in the paint tool and i have also tried to just select the landscape, but no luck!


I am glad you got it to work