Path Tracer - light not passing through the glass

Hi all,
I am still trying to figure out which engine I should use for the final production, PT or IRay, therefore I am making bunch of tests right now.

One big issue with PT is that the light does not pass through glass (even Thin-walled, 1 face object), the workaround for that I found is to turn off cast shadows, but in many cases it requires to separate the glass faces from the object which could be a lot of manual work (going back to Maya in my case).

Light passes happily using IRay.



OmniGlass_RAYS_PT_CastShadows_OFF

best regards,
Karol

1 Like

Hello @karol.osinski! This is a rendering feature that is highly requested. Right now, I believe that caustics only works in Real-Time and iRay. I suggest you try iRay for the best results. If you use Real-Time, please be sure to activate Caustics in the render setting and in the light in our scene.

I will ping the dev team to get more information on this! Here is some more information for you in the meantime.

As a side note, roughness for translucent materials does not currently work in RTX - Real time. Take a look at this post to see a possible workaround.
Is translucent glass in RTX-real time renderer possible?

Here is a more technical post you can look through: How to improve shadows ?

Hello Wendy!
Thank you very much for all the info, even though I probably won’t be using RealTime renderer due to too much of a difference in quality between this and PT / Iray.
I will have a look at those topics anyway!
Thanks for the links :)

@karol.osinski We plan to support fast convergence for translucency when caustics are not required, in RTX Interactive (Path Tracing), in a future Kit 105 release. For now, indeed you would have to disable shadow-casting, whereas you do not need to with RTX Accurate (Iray).

1 Like

Hi @PhilippeR , thanks for your reply.
Great to hear that it will be resolved!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.