Creating realistic looking glass with Real Time renderer

Hi all,

I am having a similar issue to @user79641 in his post here but the topic is already closed so I could not reply there.

Even after enabling caustics my glass is still black. Increasing ambient light value fixes the black but obviously brightens up the entire scene…

@PhilippeR disabling cast shadows does not help in my case, right?

I am curious about the World Epsilon Treshold parameter which fixes the issue up to degree. I don’t get why its description says “Lower values results in higher quality” but actually maximising it seems getting more image-based projection on specular surfaces.

Here are some screenshots:

thanks in advance!


Hello @karol.osinski
Can you compare it to what it looks like in Interactive (Path Tracing)?

Hi @PhilippeR ,

It would look more or less like this:

I am doing some testing and changed the material type from OmniSurface to OmniGlass and boosted the IOR.

It seems that the black appears where are the gaps between the outer and inner geometry shell.

If you use OmniGlass you’ll see that it looks similar in Path Tracing to what you see in Real-Time. The more complex OmniSurface is not well matched in this case in RTX Real-Time. You can increase the Max Refraction Bounces in the Real-Time render settings under Translucency, but it won’t fully solve this issue.

In Interactive (Path Tracing) you would increase the Max Bounces and Max Specular Transmission Bounces.

The real-time mode has more limitations when it comes to translucency.

For World Epsilon Treshold, the lower the value, the less image-based reprojection is used to calculate refractions, so it will look more accurate, but I am not sure it will make much of a difference in this case.

Thank you @PhilippeR . I will do more tests with the entire chandelier these days and will post the results here!

I am using the OmniGlass material but the results are still not so nice. Trying extremly low IOR helps a bit but it is still far from ideal.

Another issues is that the lights doesn’t really affect the glass using RealTime, caustics are working suprisingly well though.

Aren’t there any settings overrides that could be applied to solve this issue?