Glass become black in Real Time

Hello, the glass material is black in this scene.

(There are eyeballs inside the lenses which are supposed to be seen).

Under render settings increase the bounce of reflection/refraction and adjust the roughness cutoff value.

That doesn’t fix.
I found the problem is in the indirect diffuse lighting.

Hello @user79641. Let me forward this to the rendering team to take a look! Thanks for reaching out to us!

In the mesh’s properties, you can disable Cast Shadows.

Unless Caustics are enabled in a light (and not all light types support it) and Caustics are enabled in the Real-Time render settings then translucent materials will cast opaque shadows. For such a case as yours, disabling shadow casting should be sufficient.

It works, thank you!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.