Please help me get 10 or 12 bpc from my Quadro M2000

Hello guys,

It’s been a long time since I last posted in this forum on CUDA acceleration of Autodesk Moldflow software. But Moldflow doesn’t use CUDA anymore, so this post topis is different - namely, I’m also a serious hobbyist (or semi-professional) video DP, operator and editor, and I’ve just completed setting up my new editing suite. Following someone’s advise on another forum, I’m using a 21:9 monitor (LG) as my system monitor, and the Samsung 49KS8000 hanging on the wall directly above the LG as my video preview during editing in BlackMagic daVinci Resolve NLE program.

The Samsung SUHD “quantum dot” matrix is said to be a 10-but panel, and the guy from another forum said I’d have no problems editing my 4K 4:2:2, 10-bit color resolution/depth video on it. However, I don’t seem to be able to configure it in the nVidia Control panel as such! And here’s where I need your expert help; I realize this forum is not about playing 4K/UHD content using Quadro cards - so I kindly ask Moderators to move my post where it belongs…

OK, so I have the Quadro M2000 in my system; all its output ports are DisplayPorts so I feed my LG 21:9 2560x1080 monitor with DisplayPort cable, and my Samsung SUHD TV - since it only has HDMI 2.0 inputs - with a good quality DP-HDMI 2.0 active converter (made by Club3D), and a high quality, high speed, HDMI 2.0 compatible cable. I have the LG monitor configured as RGB full range, but of course I wanted to configure my Samsung SUHD panel as YCbCr 422 with 10bpc - but I can not !!!

What happens is: when I chose YCbCr422 and click Apply, the bpc drop-down list - only offering 8 in RGB mode - contains the choice of 8, 10 and 12 bpc, which is a good sign that the Samsung panel actually supports these (judging from the fact that when I test YCbCr with my LG monitor, which is 8bit color depth only, no other values for bpc are displayed in the drop-down list but 8). HOWEVER: when I click on 10 bps the card communicates with the Samsung panel for some 1-2 seconds, and upon clicking “Apply” - reverts to 8 bpc!

I think I tried everything (including “Enable Video Editing Mode” in the Desktop menu of the Control Panel. and “Force 10 bits per Component” in the 3D Settings - nothing works! Even though the choice of 8, 10 and 12 bits per color is offered, my Quadro M2000 and Samsung 49KS8000 only connect in one of the 2 modes:

  • YCbCr422 with 8 bps and Limited Output Dynamic range, or
  • RGB with 8bpc and Full Output Dynamic Range

BTW, the latter mode is the same I’m using with my LG monitor, which indeed is only 8bit per color capable - and due to Full Dynamic range, the RGB connection actually looks beter on my Smasung SUHD TV than YCbCr422!

Please tell me what’s wrong with my configuration… I really need full 10-bit path in my video color grading application (daVinci Resolve), as I record my UHD/4K video using the professional Sony FS7 camera with Slog3 gamma and extended Gamut3.Cine and grading it in 8 bit color is a futile exercise…

Looking forward to some advice,


Hi Piotr,

I have the same exact problem on a Dell Precision M4800 (NVidia Quadro K2100M) but if I move the monitors on another machine (Precision T5600 with NVidia Quadro K620) the problem disappears so it’s not the monitors nor the cables…

Did you solve the problem in the meanwhile?