Powering Jetson nano using GPIO (B02)

Hey! I have a brand new jetson nano B02 with 2 type C ports for power and serial communication along with 16GB in-built emmc storage.
I am using it in an autonomous mobile robot so in order to power the board I have a buck converter which steps down the 12V input to 5V that the jetson requires. My requirement is to power the jetson using IO pins name 2,4 (+5V)and the available ground pins. I cannot be using a female type b to convert the power distribution output to type C male and power it. Is my requirement achievable in B02?
I tried connecting the output of my buck converter 5V to pin 2 and GND to pin 6 on the carrier board and no response. The board works fine when powered using USB C and boots into inbuilt ubuntu 18.04

Need help, Thanks in advance.

Hi, it should work as pin 2, 4 is connected to output of type C connector on same net VDD_5V_IN. Can you share photo of how you setup such connection? Did you disable/enable the auto power on function?

Thanks for the reply. I did not touch any other pins other than the 2nd pin for +5v DC and pin 39 for ground.
I’ve attached the setup from where the buck converter outputs +5V DC

It looks fine. Did you connect pin 39 to GND first and then pin 2 to 5V? Did you probe the 5V on board to make sure board is supplied indeed? And also you can probe the POWER_EN signal to see if it is asserted when 5V attached.

Yes I connected both the terminals and turned ON the buck converter which supplies both the pins(2 : +ve, 39 : GND) with a total voltage of 5V and I probed pin 4 which received 5V. So the board is indeed getting supplied with 5V.

Another Things I noticed was that while powering the board with Type C the pins 2 and 4 were also supplied with 5V which made my buck converter turn ON.

Any guess why the board is not turning ON even though both the pins are interlinked with Type C.

It is not allowed to power supply with Type C and power pins at same time, as it could damage power source.

Have you removed all external devices when you power from pin 2 and pin 4? It is weird that system does not boot with the supply…no clue on this, maybe you can try another supply to the pins?

Tried using other power supplies too, didn’t want to fiddle with it as much, replaced this jetson with the one that has a barrel jack. So now my functionality is attained and this problem won’t be a blockage for me.
Anyway thanks for the timely replies and sorry for my delayed response. :)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.