Problem occurs when install cuda on CentOS 5.5

Dear all,

I started to install my first cuda driver today, but some problems occurred after the installation, please help.

My OS is CentOS 5.5(Final) 64-bits version, and I am using Geforce GTX 560 Ti, there is also another graphical card installed on my computer. I downloaded the driver of version 270.41.19 and finished the install process, but after the installation I cannot use “startx”, the error message was that:

Fatal server error: No screens found

My X-Window system version is 7.1.1, X Protocol version 11, Revision 0, Release 7.1.1

I don’t know what’s going on there, so can anybody helps me to fix this problem? thanks.

Did you do these or these tricks ?

If I understand your problem correctly, this is what I ran into. The symptom
is that the X window system does not start. If you look closer you find that
it is dying with an infamous signal 11 (I think) error.

There is a solution out there on the internet, it is basically to “blacklist”
the default “nouveau” driver, which is (I think) the default nvidia driver
for Centos.

According to my notes,

  1. First you install the nvidial driver with the ‘-k $(uname -r)’ flag
  2. Then you cd /etc/modprobe.d and edit modprobe.conf.dist and add ‘blacklist nouveau’
    to the last line
  3. The you cd to /boot/grub, edit grub.conf, and add ‘rdblacklist=nouveau vga=346’ as
    the last line. The vga=346 selects one of several default resolutions, again if you
    find the original poster for this information there are other codes.

Believe it or not, this worked for me.