Problem with RTX 2060 (12 GB) in Linux (Ubuntu/PopOS/Mint)

Hardware acceleration is not working (I think) due to which high CPU is being used. Tried nvidia-driver-470/495, but the issue is same.

How to resolve this issue?
nvidia-bug-report.log.gz (661.6 KB)

Please run as root and attach the resulting nvidia-bug-report.log.gz file to your post.

nvidia-bug-report.log.gz (661.6 KB)

Attached nvidia-bug-report here. Awaiting response, thank you !

You’re running a miner on gpus connected over a x1 pcie riser, there’s performance/bandwidth left for graphics.

I didn’t face any issues on Windows. How’s Windows able to do it while Linux can’t? Right now, I can’t even open a LibreOffice writer document without stopping the miner, whereas in Windows, thats not the case.

Do you have any processes running having high cpu loads?

Nothing I believe. Its a fresh Pop!OS installation with miner. Nothing else. All I have done is running TRex, nvidia-settings enabled all gpu (for overclocking). Same as Windows.

Earlier in Linux Mint, it said Hardware acceleration is not working, hence shifted to PopOS. Its working fine, but whenever I open 2-3 apps, it just gets stuck.

Please check with ‘top’ if anythings gets stuck eating cpu.

xorg it is! This uses the maximum resources whenever I open LibreOfficer or 2-3 different apps:

“/usr/lib/xorg/Xorg vt2 -displayfd 3 -auth /run/user/1000/gdm/xauthority -nolisten tcp -background none -noreset -keeptty -novtswitch -verbose 3”



Xorg is stalling, might be the driver as well as just the desktop but there’s no error displayed in the log. Does the xserver unblock after a while or does it keep frozen?

@user136275 Have you connected any external monitors and are on On-Demand Nvidia profile? If so, this happens for me too and a duplicate of High CPU usage on xorg when the external monitor is plugged in

not unblocking unless I close LibreOffice or other apps which are open. I tried opening the desktop with Wayland, which is working without any issues even though I open multiple apps, but I can’t overclock on Wayland! @generix

Any other way to resolve this?

Only one display via HDMI. But I don’t think it is the issue since Wayland on Linux or Windows has no issues with it. @user136957

I think it is the same issue.

The buggy combination is:
Xorg + On-Demand Nvidia profile + External Monitor

The problem would go away if you change any of those. You tried Wayland instead of Xorg, now try disconnecting the monitor or putting the Nvidia in Performance mode and restart the computer. It should go away.

How do I put Nvidia in performance mode? I do have only one display and can’t use the system if I disconnect it. @user136957

Go to NVIDIA X Server Settings, you can open it by typing “nvidia-settings” in a terminal window, and go to “PRIME Profiles” and select “Performance Mode”.

You’re having a nvidia-only system with the monitor connected to the primary gpu so there’s nothing to switch.

Tried keeping all the 3 GPUs under Performance Mode, but didn’t work @user136957

So there’s no way to solve the issue? @generix