Quadro FX 4600

Hi,
In the list of cuda enabled quadro products i cannot find my particular GPU “Quadro FX 4600” does it support cuda 10.0, i have installed cuda 10.0 but unable to open it

The Quadro FX 4600 is a GPU with compute capability 1.0 that shipped about 12 years ago. CUDA stopped supporting that about five or six years ago. The minimum supported compute capability at this time (CUDA 10.x) is 3.0 (Kepler architecture).

Thanks for the reply,How can i relate the cuda compatibility with the cuda version as provided the most higher cuda compatibility value is 7.5 where as the newest cuda version is 10.1

compute capability is a numerical indicator of the GPU architecture.

cuda version is a software release version of the CUDA toolkit.

The two are not directly related, however various CUDA toolkit versions support various CUDA compute capabilities:

https://stackoverflow.com/questions/28932864/cuda-compute-capability-requirements/28933055#28933055

i am using nvidia quadro 2000 GPU with visual studio 2015 while i trying to execute nvidia debug execution

i get a warning indication that “the version of driver detected is 377.83.The version of Nsight worls with only 425.99.It is recommended you install this compatible version of your driver”

so does this mean it is impossible to use nsight vision in this hardware, if so then how could we execute the cuda program

kindly provide the detailed guide for executing a cuda programme in quadro 2000

The basic problem with your setup seems to be that you are trying to run new software on completely outdated hardware and driver. My memory is hazy, but the Quadro 2000 (Fermi architecture, introduced about 9 years ago) may predate even the eariest versions of Nsight.

If at all possible, I would suggest switching to much more recent hardware. You should be able to acquire modern second-hand low-end GPUs at reasonable prices. That said:

You don’t need Nsight to run a CUDA-accelerated program.
You don’t need Nsight to debug a CUDA-accelerated program.

Get the CUDA 8 linux install guide. Go to http://www.nvidia.com/getcudaand click on the legacy release page.

Read that linux install guide carefully.

Reload a fresh linux OS that is listed as support in that linux install guide.

Download a CUDA 8 installer of your choice.

Follow the instructions in the CUDA 8 linux install guide to install CUDA 8.

Don’t ever attempt to update or change the CUDA version or driver version after that. No newer version is supported on Fermi GPUs.

On my Ubuntu 18.04, I’m trying to install Tensorflow (without XLA support) with GPU Support on my Nvidia Quadro K4200 with Compute Capability of 3.0.
Therefore i want to use Cuda 9. Is it possible to use it with Driver Version 430.50 or do i have to downgrade to 3xx?

I don’t know what XLA is. To the best of my knowledge, there is no NVIDIA product of that name.

The latest NVIDIA driver package available for Ubuntu 18.04 should support both CUDA 9 and the Quadro K4200. Are you observing something different?

XLA is a domain-specific compiler for Tensorflow which requires Compute capability of 3.5, i mixed something up there. I’m gonna edit my comment.

Well, the Quadro K4200 has compute capability 3.0 (as I see you already noted). So if XLA requires cc 3.5, you won’t be able to run it on that GPU. But CUDA 9 should run just fine. Have you tried it?

Yes. When building tensorflow from source (necessary for CC <3.5), after the .configure process (with excluded XLA support), it still tells me that the compute capability of 3.0 is insufficient.

I tensorflow/stream_executor/cuda/cuda_gpu_executor.cc:925] successful NUMA node read from SysFS had negative value (-1), but there must be at least one NUMA node, so returning NUMA node zero
I tensorflow/core/common_runtime/gpu/gpu_init.cc:118] Found device 0 with properties:
Ignoring gpu device with Cuda compute capability 3.0. The minimum required Cuda capability is 3.5.

I know nothing about Tensorflow other than that it exists. Questions about issues with Tensorflow should be directed at the relevant software vendor, who presumably has forums or mailing lists to support users of their software.

The error message you posted seems to suggest that you cannot configure Tensorflow to run on cc 3.0 hardware, even if you compile from source. But that is just a guess on my part. Check with the Tensorflow guys.