Question for 10G (MGBE) Not working

I flashed with the Marvell binary file

I’m using in-circuit program tool (Dedi prog: SF6000Plus-G2)

My program steps are as below.

  1. Detect EEPROM
  2. Erase
  3. file load
  4. program
  5. Verify

From your log, MDIO is operating normally and the PHY ID has been correctly read from AQR.
The problem is that after the AQR is reset, orin need to load it from the EEPROM to the AQR through the SPI bus.
The way to know whether it has been loaded properly is to check whether the Firmware ID has been loaded into the AQR. Here, the Firmware ID must be read as a value other than “00”.
It is judged to be a problem that cannot be solved.
So, I succeeded by erasing the EEPROM and then flashing the EEPROM before flashing the Marvell binary file to the EEPROM.

How about erasing data as “FF”?

我现在还有个问题,量phy spi cs脚是一直拉高的,不会拉低,phy为主设备但感觉并没有和flash开始通信

这个Firmware ID有什么办法可以读到呢?

When the reset of AQR is negated (in high state), AQR must set CS to “Low” on the SPI bus, and output the address with the EEPROM Read command through SPI serial output, and read the EEPROM data through serial input line.
if CS is not asserted to “Low” on the AQR’s SPI bus. It is necessary to check whether the AQR is still in the RESET state. If the CS Pin is still high even though the reset is negated, the AQR chip seems to be defective.

It is necessary to check the AQR input power and confirm that the DT file for the GPIO pin of the orin to which AQR reset is connected is set properly.

感谢您的回复,我量了rst脚,上电后在kernel过程是有拉低复位的操作,之后又拉高了,但量spi cs脚一直都是高(1.8v),reset gpio pin已经多次检查过pinmux的配置,已经配为gpio功能,应该没问题

If RST* transitions from Low to High with AQR Pin H2, check whether RST_OUT* also transitions from Low to High with AQR Pin H7.

If the above is normal, AQR should assert the “CS” signal for its processor to load the External EEPROM.

The fact that the “CS” signal is always “High” means that the AQR Reset has not worked. If the “CS” continues to be “High” even if the Main reset button on the carrier board continues to operate the Power button several times, it is clearly a defect in the AQR chip assembly or AQR chip itself. This is judged to be defective.

Another method to clarify the AQR is alive or not, checking with JTAG tool, but it is more difficult, I think.

So, Please check AQR chip again or re-assemble it (or change AQR chip)


If the AQR ID is read, it is judged that some parts of AQR functions are alive, but if the SPI CS signal is not output after reset, it is judged that the AQR chip is not functioning 100% normally if the hardware connection is normal.

So, finally, please check the hardware connection and power.

Last recommendation…
please EEPROM flashing with the file “AQR-G4_v5.6.1-AQR_Marvell_NoSwap_XFI_ID44874_VER1836.cld”

太感谢了,经过排查已经通了!我们换了个板子用的另一个phy芯片,cs脚是会拉低的,然后把开发板的flash放上去了,没有Aquantia AQR113C 6810000.ethernet:00: aqr107_wait_reset_complete failed: -110打印了,而且也读到了fw_id Aquantia AQR113C 6810000.ethernet:00: cht-FWID=1286,现在准备用自己烧录的flash试一下,烧录的固件是AQR-G4_v5.6.1-AQR_Marvell_NoSwap_XFI_ID44874_VER1836.cld

Great !!!
you can flash EEPROM with the file

Version is different but it woks also


I’m also debugging 10G speeds.
Additional Q&A regarding speed measurement will be found in the Forum.


On my carrier board, the above print statement is not displayed even if the cable is not connected to the network.
I think it would be a good idea to ask NVIDIA a question.


How do you 10G speed measure?