Release (3.0r4) 'No suitable Java found. '

Hi there,

I’ve done a new install of Release (3.0r4). I removed my previous NVPACK directory and
installed to C:\NVPACK

Previously everything worked fine. I’m now getting:

1> [dx] ERROR: No suitable Java found. In order to properly use the Android Developer
1> [dx] Tools, you need a suitable version of Java JDK installed on your system.
1> [dx] We recommend that you install the JDK version of JavaSE, available here:
1> [dx] http://www.oracle.com/technetwork/java/javase/downloads
1> [dx]
1> [dx] If you already have Java installed, you can define the JAVA_HOME environment
1> [dx] variable in Control Panel / System / Avanced System Settings to point to the
1> [dx] JDK folder.

JAVA_HOME currently points to:

C:\NVPACK\jdk1.7.0_45

Which is all present and correct.

Any ideas what’s gone wrong?

Thanks,

Steve.

I also ran into this today.
Manually invoking ant from the command line worked okay. For some reason the plugin is getting this hiccup.

My colleague was able to fix it by resetting the JDK location setting in options to JDK 1.8. (Just click on the NVidia icon)

I was able to fix it by uninstalling java sdk 1.8 and re-installing TADP 3.04.

I’m guessing it has something to do with having multiple java jdks installed.

Hmm, thanks for the suggestions, 2 more days in and I’m still no further on.

I’ve tried un-installing all trace of Java from my machine and doing a clean install of NVPack.
Still the same error.

I’m also confused by the whole “where is java” shambles.

Does NVPACK use:

JAVA_HOME,
the path in Tegra->options->JDK Location
the path in the project properties
or even just the first ‘javac’ in the windows path env-var

Should I install JDK1.8? Surely it should work with the JDK it’s actually packaged with?

If so 64 or 32 bit version if 1.8 (on a 64bit machine)?

I’ve seen warnings about using the 64 bit version, I’ve also seen posts saying that this fixes other problems.

Any from NVidia care to comment too?

Thanks,

Steve.

For what it’s worth, it appears to be failing at the dex section, as opposed to the java compilation section:

3> -dex:
3> [dex] input: blah

3> [dex] Pre-Dexing blah.jar -> classes-2022ae5aa801a939a6ec518dbaf8aa1f.jar
3> [dx] The system cannot execute the specified program.
3> [dx]
3> [dx] ERROR: No suitable Java found. In order to properly use the Android Developer
3> [dx] Tools, you need a suitable version of Java JDK installed on your system.
3> [dx] We recommend that you install the JDK version of JavaSE, available here:
3> [dx] http://www.oracle.com/technetwork/java/javase/downloads

Ok fixed it.

Installed latest 32bit JDK, set JAVA_HOME, path envvar and TEGRA JDK root- no change.
Installed latest 64bit JDK, set JAVA_HOME, path envvar and TEGRA JDK root - fixed.

Cheers,

Steve.

the Latest android-SDK-tools(24.0.2) asked for 64bit JDK. jdk_1.7 is enough.
for this issue, no need to uninstall TADP or Nsight Tegra. Just need changing Tegra Options>Tools Locations>JDK_location to your jdk home directory

victor