4.7.2 toolchain not being installed

Like this poster, I am unable to install the 4.7.2 toolchain. I’ve installed, reinstalled, uninstalled, installed full, installed custom, ran the installer to get all the download packages, then manually extracted and checked the NDK folder – all attempts resulted in 4.7.2 missing. Wireshark shows me that the NDK is being downloaded from Google, so am I correct in assuming that there’s a post install routine that creates 4.7.2?

Could you provide a direct link to a zipped file containing 4.7.2, please?


4.7.2 toolchain comes with Nsight Tegra, but not in Google NDK r8d. If you successfully install Nsight Tegra, you will get c:\NVPACK\NVNDK, that has 4.7.2 toolchain.

I guess you didn’t get Nsight Tegra installed properly. FYI, that needs Visual Studio 2010 in your systerm.

Oh FFS, I do read documents before installing things! Here’s the details on the sequence of events:

Starting point: Platform = Windows 7 x64 Professional; Visual Studio 2010 SP1 = already installed; Plenty of drive space for files.

  1. Originally downloaded Google dev kit, installed it, started developing Android apps w/ Eclipse and command line compiler for native code.
  2. After many frustrating days trying to simultaneously debug Java and C++ code, I found out about Nsight Tegra.
  3. Applied, got acceptance email, downloaded tegra-devpack-2.0-windows-2013-02-06-14961502.exe.
  4. Uninstalled Google tools.
  5. Started installation, clicked through on all the defaults, waited until finished.
  6. Started up VS2010, made sure paths were set in the options, tried my first project.
  7. Errors showed up right away, “app in use” (related to bug in build files in ndk-r8d release), 4.7.2 not found. Hmmm . . .
  8. Copied the build files from r8e, recompiled. Still “4.7.2 not found.”
  9. Looked in the folders. Nope, no 4.7.2. Selected 4.7 in the project settings, compiled, deployed on Nexus 7, set a few breakpoints. Breakpoints fail to trigger.
  10. Figuring I did something wrong, closed everything, then started Nsight Tegra install again, selecting full install.
  11. After waiting a long time for install to finish, check for 4.7.2. Nope, still not there. Started VS2010 again anyways and used 4.7. This time breakpoints successfully triggered.
  12. Still wondering where 4.7.2 got off to, I google-fu to this message board, see the above referred message about wonky installs and the NVNDK subfolder, so I did a complete uninstall and started all over again.
  13. Installed Express selection – no 4.7.2, no NVNDK, uninstalled.
  14. Installed custom – no 4.7.2, no NVNDK, uninstalled.
  15. Installed full – no 4.7.2, no NVNDK, didn’t uninstall.
  16. Started install, waited until all files downloaded, then manually extracted all the files – still no 4.7.2 and no NVNDK.
  17. Tried a custom install again for just the NDK, fired up Wireshark to see where the DL was coming from, the GET command from the installer was: “http://dl.google.com/android/ndk/android-ndk-r8d-windows.zip
  18. Came here and posted in frustration.
  19. Started up my Windows test machine w/VS2010 already installed on it. Installed Nsight Tegra. Guess what? That’s right! No 4.7.2, no NVNDK!

I’ve already wasted too much time on this. Can’t someone just zip up the NVNDK folder for me and post it somewhere? It’s open source for cryin’ out loud and not some trade secret.


After installing Tegra DevPack you will usually end up with 2 NDKs installed: one is the Google’s vanilla r8d and one is NVNDK. There is a possibility of Nsight Tegra installer doing something wrong and installing the NVNDK into Program Files, and not C:\NVPACK. Could you please search manually for the arm-linux-androideabi-4.7.2 folder on your computer?

If NVNDK will be found somewhere on your machine, please ensure that its path does not contain spaces (move the whole NVNDK folder somewhere else otherwise).

Well, I was coming here to say that I installed a vanilla Windows 7 on another machine, installed VS2010, then VS2010 SP1, then installed Nsight Tegra, and finally got NVNDK with 4.7.2.

So just for you, I checked on my main machine: “C:\Program Files (x86)\NVIDIA Corporation\Nsight Tegra 1.1\NVPACK” contained “android-ndk-r8d.exe” and “ndk-uninstall.bat”, but no r8d or 4.7.2 folders existed anywhere else. I’m running an administrator account, the permission settings on the folder tree and files show full control for admins, and I don’t have any policies other than the standard W7 ones.

As a test, I renamed the NVPACK and Nsight Tegra 1.1 folders to make sure the installer wasn’t having problems overwriting or deleting files, and re-ran (yet again) the installer. Same thing, no NVNDK. But I can manually run the r8d.exe in the Nsight Tegra 1.1 folder and self-extract it to C:\NVPACK\NVNDK.

I kept an eye on the installer and folders as it was running. There was no extra ndk installation action after the ndk extractor filled the C:\NVPACK\android-ndk-r8d folder. Perhaps you have a timing issue in your installer? If the android-ndk-r8d.exe file isn’t available by the time the installer gets to installing it (because of a busy system or background services), your installer may just bypass it. I did note that the environment variables on my main machine for the ndk were pointing to C:\NVPACK and not C:\NVPACK\NVNDK like on the vanilla test install machine, so the installer didn’t even get to that point in the script.

I am also getting a warning in the 4.7.2 compiler with my project that: “note: the mangling of ‘va_list’ has changed in GCC 4.4” in jni.h for a bunch of compiled files. This is extremely annoying and doesn’t happen with the 4.7 toolchain. For now, I’ve included “-Wno-psabi” in the compiler options, but obviously this isn’t the correct solution. Could you patch this in the next version of your software?

Thank you for your post!

We’ll definitely investigate the installer issue. As for the ‘va_list’ problem, I’ll see if I can reproduce it. Did you import the makefile-based project or did you create one that does not require .mk files from scratch?

I imported a makefile project (which uses the JUCE library).


Did you try to build your project from the command line using ndk-build and the 4.7.2 toolchain? If so, did the warnings appear? I tried to do it that way too, but still didn’t get any.

Sorry, didn’t see your question until now.

Yes, I got the warnings both on a command line build and in VS. I did have to modify some of the JUCE code to get it to port better to Android, so that may have triggered the warning somehow (weird, since 4.7 doesn’t give a warning). I’ll have to refresh from the repository and try the JUCE demo compilation to see if it’s in the stock code.