Replicator Composer - objects is not dropped and overlapping

Hi, I’m following Replicator Composer tutorial and tried to run sample file (warehouse.yaml) as below

python.bat tools\composer\src\ --input parameters\warehouse.yaml --output *\datasets\warehouse_test --mount C:\Users --scene-num 10

but when I open the result images the objects is floating. I want objects to be dropped and not to be overlapped. Even if I added “obj_physics: True” to warehouse.yaml, it wasn’t resolved. what to do?

Thanks in advance.

Hi @daisuk , this is because the scene’s gravity is by default set to 0. If you want the item to be dropped, you can add a new parameter in your yaml file. scene_gravity: 9.8, which is the earth’s gravity constant.

Hi @jiehanw , thank you for your reply.
I tried that, but not improved. I checked the manual for the Replicator composer parameter list and found that the scene_gravity value should be set with a Boolean type, so maybe I should use boolean type?
I added

obj_physics: True

to the warehouse.yaml file as well. but not improved. Is this a kind of bug?

Came across this thread with a possible solution, potentially worth a try - Object Physics (obj_physics) not working in Replicator Composer. Objects are still flying - #12 by sebastian.reicher

@daisuk So the warehouse is not a sequential scene, it is a per-frame randomization scene, so the physics is not played. To turned it in to a sequential scene, you need to set the sequential: True just like the flying_things_4d example.