Physics simulation in Replicator/Docker/OVX - strange results


I am trying to run a simple simulation with physics in Replicator, using the Docker image v1.6.3

The scene has a torus falling down on a plane. I am writing out the RGB sequence. Looking at the results, I have the following issues:

  1. The object seems to start falling, then at frame 16 stops falling in mid-air. Then it starts moving sideways and in the end falls below the plane. When I run the script in interactive Isaac Sim instead, I do not have this issue - the object falls onto the plane as expected.
  2. In the log there is an error: 2023-04-27 08:00:48 [16,844ms] [Error] [omni.physx.plugin] Physics scenes stepping is not the same, step subscription will be send with later step, per scene step is not yet supported.
  3. I am not sure if the gravity constant is set correctly by default. It seems the replicator api has no way of setting it explicitly.

Any help welcome!

simulate.log (37.7 KB) (1.1 KB)

1 Like

To illustrate, let me attach a video where I run the sequence of images as a clip.
2023-04-27 11-45-04.mkv (3.8 MB)

Regarding 2. and 3., I was able to create a physics scene like this:

The error does not occur anymore. The function _setup_physics_scene() is not part of the official API though. It also seems that it is used nowhere from within Replicator code, but I am not sure.

Problem 1. persists, though.

Hi @bruno.vetter ,

I just used your code to test on Replicator 1.6.3 and I get the same physics error ( [Error] [omni.physx.plugin] Physics scenes stepping is not the same, step subscription will be send with later step, per scene step is not yet supported.) but the torus drops onto the plane as it should - I am not seeing this strange behavior.

Are you using replicator through Code or Usd Composer? If so what other extensions do you have turned on that are not on by default? Maybe there is some other imported package conflicting with something and causing the issue?


Hi Henry,

I am using the Docker image for Replicator 1.6.3 provided by Nvidia. I run the Docker image on an OVX running Ubuntu.


Hi Bruno,

I was able to repro this using docker with 1.6.3. It is units bug that was fixed some time ago, but didn’t show up on my local build of replicator because it didn’t have physx /isaac in it. Can you use the latest version of Isaac production app on the launcher? It should have replicator 1.7.8, and I just tested it and it does not have the issue. Alternatively, if you can get the docker image it is fixed on replicator 1.7.7 too.


I agree this problem does not show up in Isaac Sim, but there is no version 1.7.7 Docker image available here: Omniverse Replicator | NVIDIA NGC

The newest version is 1.6.3 unfortunately.

Hi Bruno,

I’m sorry about the delay.

This was a pretty nasty bug - took us some time to work through it. However, we have a workaround that should fix this specific case. I attached the code here.

Meanwhile, I’ve tried to expedite the public release of Replicator 1.7.7, which is a much better solution to this. I had thought it was released publicly already but was wrong.

Let me know if the workaround works for you.

-Henry (1.8 KB)