Request: Install Linux Headers on Jetson Nano

Essentially I would like to perform the following install
sudo apt install linux-headers-$(uname -r)

However, it throws up the error

E: Unable to locate package linux-headers-4.9.140-tegra
E: Couldn’t find any package by glob ‘linux-headers-4.9.140-tegra’
E: Couldn’t find any package by regex ‘linux-headers-4.9.140-tegra’

I found bits and pieces where people downloaded the source_sync.sh and run, but I have been unable to find a guide or walkthrough of the process.

If someone can provide a walkthrough, or even just point me to the documentation that I should be reading, that would be greatly appreciated.

Cheers,

B00l3an

Have a check below document for kernel customization.

https://docs.nvidia.com/jetson/l4t/index.html#page/Tegra%2520Linux%2520Driver%2520Package%2520Development%2520Guide%2Fkernel_custom.html%23

There does not seem to be a sign for the beginning script ./source_sync.sh on the jetson nano

Sources_sync in in the Linux_4_tegra folder in sdk manager’s default location on PC. I had got start a thread to find it as well, iirc, but the search function is yielding no results.

Edit: it was l4t home that I couldn’t find (which sources sync is in)

Cheers mdegans,

Did you mean the https://developer.nvidia.com/embedded/downloads page? I found a sources_sync.sh in the L4T Drivers archive. But not sure this has the linux headers I am looking for

No, this accursed thing:

https://developer.nvidia.com/embedded/dlc/nv-sdk-manager

  1. Install it and it’s dependencies on an Ubuntu 18 desktop machine (preferably a separate install to your main Ubuntu).

  2. You will find sources_sync.sh in the install path in a subfolder called Linux for tegra. Perfectly clear, no?

If you’re confused, don’t worry, you’re not the only one.

Thanks so much.
Gonna give this a go!

And yes I am confused, so SO confused.

If you want, there is a thread on a broken firewall on the forum where I documented my problems I ran into customizing the kernel and going from there to a flashable image:

https://devtalk.nvidia.com/default/topic/1051327/jetson-nano/jetson-nano-jetpack-4-2-firewall-broken-possible-kernel-compilation-issue-missing-iptables-modules/post/5342025/#5342025

B00l3an, did this work for you? I download the sdk but its x64 and not arm based. So i cant install the pkg.

sudo dpkg -i sdkmanager_0.9.14-4961_amd64.deb
dpkg: error processing archive sdkmanager_0.9.14-4961_amd64.deb (–install):
package architecture (amd64) does not match system (arm64)
Errors were encountered while processing:
sdkmanager_0.9.14-4961_amd64.deb

I thought all nanos were arm based?

I am trying to get Wowza running on the nano and the only step I am unable to do is get the headers installed.

RESOLVED: Figured out what I was missing.

Hi, May I ask how you got wowza running on the jetson nano? Thanks

In order to get an arm based copy of wowza you need to contact wowza sales. Once you get that package from them you should be able to install and run it. Although i was able to get it to start up, including the manager, if you try to transcode it will throw an error. At the time I tried this, the wowza arm binary did not support transcoding on the arm system. I did not go any further since my only interest was in transcoding.

There is a page on the wowza site that will walk you though installing on a Raspbery Pi. Those are the instructions I followed.

If you have specific issues that you need help with I can try and assist.

You would likely have to ask their support for an arm64 version that supports the acceleration mechanisms of the Jetson Nano. An out of the box arm or arm64 client would likely work, but drop frames at high resolutions.

Apparently wowza does support streaming rtsp so you could use gstreamer as a client and it should just work. You should be able to use that article and this post to get it owrking.

You might be interested in this. “source_sync.sh” can install full kernel source if you know the release name which matches the current kernel, and if used in the right way can probably do what you want (although not as a package):
https://devtalk.nvidia.com/default/topic/1051980/jetson-tx2/how-to-upgrade-linux-headers-4-4-38-tegra-to-latest-kernel-and-headers/post/5339991/#5339991

Hi, THanks for the reply, I have just emailed the sales team at wowza to ask for an arm64 copy. Thank you!

I don’t understand how any of the replies address your question. Did you resolve the problem? how?