Revit Connector issue [Send to view failed]

Hi everyone,

After we installed all necessary tools, when open revit sample file, and click send to view, a folder and some files were created, but the forder only 14kb intotal, and nothing displayed in view. We also use publish to export the file, the result was same, but SU just works fine.

Please help us to solve the issue with Revit, thanks.


I see that SketchUp is working fine for you. That means you are publishing to localhost, meaning that you installed a Collaboration server. Correct?

When you publish the Revit sample, did you save it to local disk or to Omniverse (localhost)?

There is more to the Revit file than it appears in Omniverse. There is a top-level project.usd which is usually very tiny (14k sounds about right). But if you look in Project Files, you will find another folder for that model. Digging in one level deeper and you’ll see the USD for the Revit file.

SketchUp, Rhino and Revit save to a project structure in Omniverse so that you can save a number of different models to the same project and they will not erase/overwrite each other.

If you could include a copy of the Publish dialog when you save from Revit, that would be appreciated. Here is what I utilize:

And here is what it looks like in Omniverse (in Chrome, you can go to localhost:8080 to look at Omniverse on your system):

For me, the rac_basic_sample_project.Revit.usd is 6Mb.


Hi Brian

Thanks for your reply, and yes, we have installed a Collaboration server.
The following is our Publish Dialog.

In Chrome, with accessing localhost:8080, we got this

The publish result was still not working, and we can see the real usd file size was 1.75KB.
Thanks for your help.

There is a fix for Revit in 100.2.0 which corrected a problem with Send to View publishing for some models. I suggest updating to that and try again.

A couple of other questions:

What version of Revit are you using?

Have you tried just publishing the file and see if that works compared to Send to View?

And if all of that still fails for you, would you mind sending me the rvt file to try?



Hi Brian
Thanks for Your response, and we have update the Revit connector to the latest 100.2.0, but the issue still exists.

And the Revit version we used is Revit 2021( 20200220_1100(x64)). We also tried publishing the file to the local drive, but the results was the same.

We used the Revit model “rac_basic_sample_project.rvt” as follows. Looking forward to your suggestion. Thanks.

Have you tried other models from Revit? Did you get the same result?

Also, are you using a professional or educational license for Revit? I’m using a professional one so I just wanted to compare in case I’m missing something.



Hi Brian

Thansk for your help, and we finally solved this problem on another machine, with the latest version from the official release.


1 Like