Cannot transfer a model from SketchUp 2020 to Omniverse view

When I click on the green airplane button in Sketchup 2020, it takes a couple of!minutes when Omniverse is launching (sofar so good). But then I get this error: "Cannot list omniverse://localhost/Users/my username/SendToView … Result.ERROR_NOT_FOUND Then it opens a WELCOME TO NVIDIA OMNIVERSE screen with files I cannot open. Even the sample SimpleHouse will not open Failed to open error. What is going wrong?

Did you install the Collaboration server? You need that for publishing a model.

Yes I did and I signed in. I can open the model later when I choose in the menu open>local host> … That is working, but not directly by clicking the green airplane button. And I noticed strange things happens with the vegetation in the model, see both images SketchUp and Omniverse

That + sign in the name is throwing us off … I know, silly.

We have a hotfix posting tomorrow night that will fix that for you for Send to View (green airplane)

So, we map vegetation or really any Component in SketchUp to other things, if you want.

Look in C:\Users<user name>\Documents\Omniverse\SketchUp and then open up omniverseSketchUpPlanttable.csv. This is our mapping table for things in SketchUp. It does NOT have to be for just vegetation. The second column is where the decision is made … if a component name in SketchUp matches this (case is irrelevant), then it maps to the USD asset in column E found at the Nucleus Collaboration server path given by column F.

If you remove the offending line, you’ll get back things exported from SketchUp as they are. However, maybe it just needs to be a different mapping.

If that still does not work, I could take a quick look for you if you want to send me the model.

Okay thanks a lot. It’s getting late here. I will try it again after installing the hotfix and let ik know.

wow, that is a complicated workaround to import SketchUp models into Omniverse, not a one click action. I hope this get better. I send you the SU file.

It’s meant to be flexible. If you do not want any assets to map, just delete all the entries in that CSV file.

Removing line 30 (boxwood), it will keep your hedges. Our boxwood is not a hedge but rather a rounded bush for a boxwood. Agree the mapping is now what you were expecting.

We’ll add a switch to allow you to toggle usage of the map on/off rather than any hand edits.

Does that make sense?

Thanks Brian, I like the idea of a switch. Looking forward to this improvement.


Hi Richard,

I thought about it some more. It will be in a hotfix first week of January along with some other setting defaults so it’s easier to control.

Appreciate your feedback.


Thanks Brian. I see it in Januari. Have a nice day!


Maybe more export settings in the dialog box, like this one (Twinmotion)