RTX lidar hits the Mirror and there is no reflection

I was testing the RTX lidar. I placed a Mirror wall in front of it, but after the laser was applied, it did not reflect back. I want to know if it can be realized that when the laser hits the glass, it can be reflected. Because I have used glass, the glass material can be directly penetrated.

I am currently trying to figure out how the Rtx Lidar works but my first guess here ist that you only applied a visual glass material to the wall and didn’t map it to the glass sensor material. Check out this Dokumentation and it’s subchapters on how and where to configure your RTX Lidar.

lstrauss is correct.
Note the visual material does not affect the sensor material.

As for how a mirror works with sensors, I think a retro reflective material would reflect back with the most intensity, but if that beam was reflected onto the ground, then I’m not sure the sensor would pick up that as a second return.

@mcarlson1 @lstrauss

Thank you for your help. I have also seen related questions about “number of returns” in other forums, but I didn’t find any place where I can set it. Can you tell me how to set it up? Thank you very much.

Its in the lidar config file. its the maxReturns setting

@mcarlson1

@mcarlson1

Sorry, I still haven’t gotten it to work.
First, I made json and placed it in “Nia/4/isaac_sim-2023.1.0/exts/omni.isaac.sensor/data/lidar_configs/config/config.json”. The content of json is the content in the screenshot, and I set The glassmaterial is in my csv file. And added RTX Lidar, it still doesn’t work. It didn’t penetrate the glass. Is there something wrong with my configuration? I can’t find anything wrong with it.



However, when I tried to run the code to create the RTX Lidar, it reported an error. The error is shown in the picture.

You will get that error when the omni.isaac.sensor extension is not enabled.

Also, I notice you created a new config folder… you will have to add that to the setting in omni.isaac.sensors extension.toml file alongside the rest of the configs for the lidar to see it.

@mcarlson1

  1. I enabled omni.isaac.sensor. It is enabled by default.

  2. I created a new folder and reconfigured it in omni.isaac.sensors extension.toml but it still reported an error.
    When I delete this folder (exts\omni.isaac.sensor\data\lidar_configs\Configs\confis.json) it works fine. The code can be run, but it still does not penetrate the glass material (I have added the glass material to the csv file.)
    I’m not sure whether there is a problem with my configuration file configs.json or my configuration path (the screenshot has been uploaded)

  3. When I place configs.json in (exts\omni.isaac.sensor\data\lidar_configs\confis.json) and use the default omni.isaac.sensors extension.toml, it can also run the code, but it doesn’t seem to work. It has no effect and still does not penetrate the glass material.

well case matters. For example. Example_Rotary will work but Example_rotary will not.
Also, with that red ! point by the extension, it is not loading correctly.
If the extension is loaded, and the config file is not found then you will at least get a printout telling you the folders is searched and the config name. If you don’t even get that, then the omni.isaac.sensor extension is not loaded.

Maybe something broke in your installation and you should try a fresh install.

@mcarlson1

Thank you very much for your reminder. I have reinstalled and updated to Isaac Sim 2023.1.0-hotfix.1 and configured the files, but it still does not work properly. My system is windows 10,I have uploaded all the configuration screenshots. I hope you can help me find the reason.




4

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.