How to set the parameters of RTX lidar?

I’m very sorry that I encountered some problems during use:

I added an RTX Lidar and connected it to ROS. Because I don’t need a point cloud, I just want laser information, and it can penetrate glass, etc. Similar to PhysX Lidar, get data. I’m not sure if my approach is correct. I got the Ros information as shown in the picture. But I encountered two problems:

  1. How to adjust the parameters of RTX Lidar. I did not find the same parameters as PhysX Lidar, such as MaxRange, minRange, horizontalFov, horizontalResolution. Where are these parameters specifically?

  2. Is it possible to obtain the same data information as PhysX Lidar through RTX Lidar?

Hope I can get some help, thank you very much.

Hi, maybe the RTX Lidar Documentation holds the information you are looking for. I remember it mentioning a configuration file.

Thank you very much for your help. I read the documentation carefully and made it according to the documentation, but I encountered an unknown problem.

  1. I opened the extension.toml file and saw its settings, which are set by default. (Screenshot below)

  2. I added myglass to RtxSensorMaterialMap.csv, created a new omniglass in the scene, and changed the name to “myglass” (screenshot below). However, the simulation results are still not what I want, and the lidar still does not penetrate the glass material.

I’m not sure where my error is and would appreciate some help.

For a block with the myglass material, you should get a hit on the glass at first, then if your max number of returns is high enough in the config file, you should get a 2nd return as it exits the glass and a 3rd return from the ground behind the glass.

It’s hard to tell from the image, but it looks like you are getting returns from both sides of the myglass block, so your number of returns is at least set to 2 I think.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.