SDK Manager can not log in to developer.nvidia.com

Hello,

I have been trying to install the JetPack 4.2 on the Xavier via the SDK Manager.

The issue here is that SDK manager could not login to the developer.nvidia.com
from the inside proxy location with the following log.

I can login it from the proxy location by the browsers, chrome on win10 and ubuntu18
but not by sdk manager. So, I could post this topic.

Does anyone have any suggestions to go further?

  • SDK Manager log

2019-05-24 20:07:39.009 - info: check for update frequency set to 43200
2019-05-24 20:07:39.013 - info: Is updates check enabled set to true
2019-05-24 20:07:39.013 - info: Begin to create timing task for auto update.
2019-05-24 20:07:39.076 - info: Create timing task for auto update successfully.
2019-05-24 20:07:56.863 - info: Logging in with sso login method…
2019-05-24 20:07:56.875 - info: posting login request. url: https://devzone.auth0.com/oauth/token
2019-05-24 20:07:58.981 - info: posting login request. url: https://devzone.auth0.com/oauth/token
2019-05-24 20:08:02.565 - error: devzone signIn error, took 5.69s. errors(developer/user db): UNABLE_TO_GET_ISSUER_CERT_LOCALLY UNABLE_TO_GET_ISSUER_CERT_LOCALLY
2019-05-24 20:08:02.567 - error: loginManager.login failed: wrong_user_or_password
2019-05-24 20:08:22.313 - info: exporting logs from /home/shino/.nvsdkm/logs

  • other information

  • SDK Manager 0.9.11.3405

  • OS: Ubuntu 18.04.2 LTS

  • The above machine is inside the proxy.

  • SDK Manager Screen image

Login to developer.nvidia.com
incorrect email or password

  • I with sdk manager have some options to ignore above erros.

It seems this topic is categorized to the answer but I intended it as question.

Is there any way to change it to question?

Hi shinos9q35,

So this issue happened at your netwotk environment with proxy? Have you manually added proxy setting at SDK managers? See: https://docs.nvidia.com/sdk-manager/sdkm-settings/index.html#sdkm-settings

Thanks

Hi kayccc,

That happened after I set the proxy settngs on SDK manager.

Probably, the proxy settings were correct because SDK manager got timeout without the proxy settings.

Is there any option to skip certification verifcation on SDK manager?

Hi,

I would like to know the cause of the following log.

2019-05-24 20:08:02.565 - error: devzone signIn error, took 5.69s. errors(developer/user db): UNABLE_TO_GET_ISSUER_CERT_LOCALLY UNABLE_TO_GET_ISSUER_CERT_LOCALLY

Does anyone know that?

I will go with JetPack 4.1.1 Developer Preview until the solution will be found.

Any suggestions around “UNABLE_TO_GET_ISSUER_CERT_LOCALLY” is welcome.

For someone who is kind enough, I will put the current status.

  1. Host: Ubuntu 18.04.2 LTS
  2. Device: Xavier
  3. Network: Host and Xavier have been inside proxy.
  4. Devzone account: activated.
  5. SDK Manager: 0.9.11.3405
  6. SDK Manager proxy settings: done
  7. Connection from the SDK Manager@host to the devzone: should be OK except certification issue.
  8. SDK Manager log is shown below.
  9. Note: I have finished the installation on Xavier with JetPack 4.1.1 Developer Preview.
    Network related tools of apt and others worked with current conditions.

2019-05-24 20:07:58.981 - info: posting login request. url: https://devzone.auth0.com/oauth/token

2019-05-24 20:08:02.565 - error: devzone signIn error, took 5.69s. errors(developer/user db): UNABLE_TO_GET_ISSUER_CERT_LOCALLY UNABLE_TO_GET_ISSUER_CERT_LOCALLY
2019-05-24 20:08:02.567 - error: loginManager.login failed: wrong_user_or_password
2019-05-24 20:08:22.313 - info: exporting logs from /home/shino/.nvsdkm/logs

Under above situation, how can I install the Xavier with JetPack “4.2”?

Hi, shinos9q35,
Can you try to use SDK Manager Beta 12 to see if the issue still exists? https://developer.download.nvidia.com/sdkmanager/client_update/sdkmanager_0.9.12-4180_amd64.deb

Do you have root certificate installed on your host machine, such as installed it to /etc/ssl/certs with update-ca-certificates?

Dear changbins,

Thank you so much for new SDK manager. It has worked under my environment.

The answer of the following question is that “I have not installed the root certificate.” However, I “GUESS” the proxy server which I do not manage might do that.

Do you have root certificate installed on your host machine, such as installed it to /etc/ssl/certs with update-ca-certificates?

By the way, new SDK Manager has a good improvement that it can get the prosxy settings from the system. Things have been getting better and better.

Regards,
shino

Hi shino,
I am glad to see that the issue is now resolved on your end. Yes, using system proxy configuration is now supported in SDKM Beta 12.

Thanks for your feedback to SDK Manager, we appreciate it!

Dear changbins,

I have the same problem with shinos9q35. I also have been trying to install the JetPack 4.2 on the Xavier via the SDK Manager. I can log in it through browsers, but not by sdkmanager.

I can not log into nvidia.developer.com using SDK Manager Beta given in the following website.

https://developer.download.nvidia.com/sdkmanager/client_update/sdkmanager_0.9.12-4180_amd64.deb

As you guided, I installed root certificate in /etc/ssl/certs with update-ca-certificates by following the following link but ended up with no success.

https://help.ubuntu.com/lts/serverguide/certificates-and-security.html.en

Is there any other method to solve this problem?

Thank you very much.

Best regards,

Sunghun

It should be “developer.nvidia.com”, not “nvidia.developer.com”. Don’t know if that is just a typo, but if not, then that would be why.

Dear linuxdev,

That is just a typo. I used developer.nvidia.com.
Still there is no success…

hi Sunghun,
Could you provide the details that how the proxy server is set up?

Dear changbins,

Of course. I do not exactly know how to achieve proxy server setting in Ubuntu, but the proxy server setting which I get by typing wget http://google.com is as follows.


nvidia@jetson-0423318035468:~/Sensor_RPLIDAR$ wget http://google.com
–2019-06-20 18:52:59-- http://google.com/
Resolving google.com (google.com)… 172.217.31.238, 2404:6800:4005:80c::200e
Connecting to google.com (google.com)|172.217.31.238|:80… connected.
HTTP request sent, awaiting response… 301 Moved Permanently
Location: http://www.google.com/ [following]
–2019-06-20 18:52:59-- http://www.google.com/
Resolving www.google.com (www.google.com)… 216.58.200.68, 2404:6800:4005:811::2004
Connecting to www.google.com (www.google.com)|216.58.200.68|:80… connected.
HTTP request sent, awaiting response… 200 OK
Length: unspecified [text/html]
Saving to: ‘index.html’

index.html [ <=> ] 12.21K --.-KB/s in 0.008s

2019-06-20 18:52:59 (1.53 MB/s) - ‘index.html’ saved [12498]

nvsdkm.zip (8.18 KB)

hi Sunghun,
It seems you are not using proxy. Please check: Launch SDK Manager -> Click top right corner “Setting Menu” -> Settings -> Proxy Settings.

Could you package ~/.nvsdkm folder on your end and upload in this post?

Thanks!

Dear changbins,

Yes, I uploaded nvsdkm.zip in the previous comment.
Thank you very much for your help.

Hi Sunghun,
According to ~/.nvsdkm/sdkm.log, your tried several times to sign in with your NVIDIA developer account.
At first it seems that you entered the wrong username/password, and finally it causes your account is blocked.
Please go to your inbox of the email account and follow the instruction to unblock it.