SDKManager: CUDA not installed if flashing is skipped

I have the Jetson TX1 with the Orbitty Carrier and I’d like to install the L4T r32.2.1 (with Jetpack 4.2.2).
Following the instructions here: I’m skipping the flashing of the Jetson, and then use CTI’s dedicated script. The script works fine, and the Jetson does get flashed, however, something I didn’t notice at the first go is that CUDA installation in the SDKManager is skipped when I’m skipping the flashing step. I’m using version of the SDKManager.

I tried to install CUDA following these steps: but after a reboot the system crashes (I’ve experienced this in the past and the cause was that I didn’t have the right Nvidia drivers installed).

I also tried with Jetpack 4.3 but not only CUDA is not installed, but also then I’m unable to log in to Ubuntu: once Ubuntu loads the login GUI, I choose my user, type in the password, and the GUI restarts so that I need to choose the user again (a problem with Nvidia drivers? IDK).

I know there’s a couple of problems here, and I have contacted CTI about it, but the questions I’d like to ask here are:

  1. Is the skipping of CUDA installation by SDKManager a bug?
  2. Is it because CUDA 10.2 (that’s the version I tried to install manually and that’s the version that SDKManager is using) does not support the Tegra chipset on TX1?
  3. Suppose I’ll flash the Jetson with L4T 32.2.1 (using Jetpack 4.2.2) and CUDA is not installed, should I install Nvidia drivers before attempting to install CUDA? If so, where do I find those (for ARM64)?

I would appreciate any hints / suggestions you guys might have.



The steps should looks like this:

  1. Flash TX1 with sdkmanager
  2. Install CTI-L4T-V0XX.tgz package
  3. Install libraries from sdkmanager.

Your installation looks correct to me.
The problem occurs from installing the CUDA toolkit.

The package downloaded from website is out of date since we redirect user to sdkmanager/JetPack for a while.
More, there are some dependencies between driver and toolkit so it will be good to use the package integrated into the same sdkmanager.

So after flashing, please use sdkmanager to install the component directly(skip the flash step).



Thanks for the answer!
OK, regarding:

  1. Flash TX1 with sdkamanger

in the instructions ( it’s said to “Click to Skip flashing the Jetson with the SDK Manager, as this is done at a later time” and then follow through with their script. And that works fine, but CUDA installation is also skipped.

Now, regarding:
3. Install libraries from sdkmanager

do you mean:

  • run sdkmanager on your host machine (a standard desktop) with Jetson connected? If so, are there any instructions on how to do that? Because all the ones I saw are talking about flashing the Jetson and what I understand by that is: install the OS along with additional libraries


  • run sdkmanager on Jetson, after the flashing is done? If so, where can I find an arm64 version of the sdkmanager?

Thanks so much for your help, I really appreciate the time!


Sorry for the late update.
Please configure the STEP02 as this:

This will skip the ‘Jetson OS’ but only the ‘Jetson SDK Components’ installed.


FYI, JetPack/SDKM never runs on the Jetson. JetPack can run as a front end to flash software if the Jetson is in recovery mode. You can disable flash and just add packages. If you do flash, then the flash ends with the Jetson rebooting. After this JetPack is able to add packages via the user account on ssh. JetPack/SDKM can download packages for install on the host PC, but also downloads the arm64…which is copied to the Jetson and used for install on the Jetson, not the PC.

Note: If you do not use recovery mode, then you are guaranteed no flash can occur. Conversely, if you are in recovery mode, then you are also guaranteed that no optional packages can be installed on the Jetson.

1 Like