Serial console USB adaptor odd behaviour

Has anyone else found that a USB-serial adaptor connecting the Nano’s serial console to a host computer can stop working when the Nano is reset or power-cycled?

I have a USB-serial adaptor connecting the Nano’s serial console on J50 to a USB hub that’s built in to my monitor. If I power-cycle the Nano, or reset it using the reset button pins on J50, it stops working; it is still recognised by the host computer but no further characters are transferred and neither the transmit nor receive LEDs on the adaptor flashes. The Nano seems not affected and reboots normally. To get the adaptor to work again I have to unplug and reconnect it to the Nano - i.e. on the serial side, not the USB side.

My guess is that perhaps the Nano doesn’t like that a voltage is present on this input while its own power supply is absent. I am concerned that this could be damaging the board; is there any protection on those inputs?

Has anyone seen anything similar?

To answer part of my own question: the console serial pins seem to be pretty well protected against applying voltages when the board is not powered; there is a TXB0302 level converter which is tolerant up to 6.5 V.

Hi,
We use the cable to connect J50 pin #3 #4 #7 with host PC( Linux Ubuntu). DoDon’t observe the issue after rebooting. Are you able to try this case?

Interesting! Are you saying that you see the issue with that particular cable, but not with others? That link is just a Google search for “tx rx cable”. I doubt I see exactly the same product when I search that you do. The one I was using was this one:

https://www.hardkernel.com/shop/usb-uart-module-kit/

It has a CP210x chip and very few other components. What chip does your problematic cable use?

I have also tried with a true RS232 cable connected to a 3.3V level shifter powered from the Jetson, and that does seem to work reliably (for the time being).

At that URL I see this:
CP2102N: USB to Serial UART bridge IC with 1.8~3.3V interface

It should work if the cable is actually using 3.3V, and it should fail if using 1.8V.

The Hardkernel product outputs 3.3 V. The inputs may work at 1.8 V; I don’t think I’ve tried it. It works fine with the Jetson, until it doesn’t.

I’ve had a look at the CP2102N datasheet. The “absolute maximum ratings” table (3.10) says the maximum voltage on the UART pins when the supply is < 3.3 V is the supply plus 2.5 V. So if the supply is off (i.e. not connected to USB) and you apply 3.3 V to the UART pin, that’s beyond the absolute maximum and may damage the device. (I guess it will latch up.) My adaptor doesn’t seem to have any components to mitigate this.

This isn’t what I’m seeing though - it’s not after replugging the USB connection that it fails, it’s after power-cycling or resetting the Jetson. I wonder if something in the Jetson power supply / reset circuit causes the UART output voltage, i.e. the supply voltage to the TXB0302 level shifter, to glitch upwards? I will investigate with my scope at some point.

Hi,
My apology. I made a typo. We don’t observe the issue with the cable. Sorry for the confusion.