Set gravity for custom asset

Hello, I’m modifyng the simple stack scenario from the leonardo preview. I loaded a custom asset following the documentation and added to the scene first loading the USD paths in the scenario.py file, then adding it in the CreateBlocks() function of simple_stack.py and registered the asset as shown in the leonardo samples tutorial.

When I start the simulation the objects doesn’t fall to the ground following the gravity, whereas with the cube objects it happens. What should I do?

Hi,

Seems like some physics components are disabled for the new primitive.
In order to simulate the physics, it is necessary to add some physics components in the original USD (or in the loaded scenario, but this way does not store the changes): PhysicsAPI, CollisionAPI, MassAPI:mass

Use the tab PhysX Properties and add those components with the comboBox Add Prim Component. Also, set up the mesh of the collision components (and, change the mass of the body if you want). After that, save the changes File > Save

I reproduced your steps, enabling those components for the mesh (Body_217) of the Isaac/Props/Flip_Stack/bearing_pin.usd asset (also, I disabled those components for the blue block just for test) and everything is working according to the physics law (except the blue block because its components are disabled).

Thank you, very helpful, as always