Simple gst-launch playback on A100?!

I’ve just stated toying with gstreamer and deepstream (ngc container 6.1) on a machine with a A100, and cannot figure what to change in the second cmd below to get it to work like the first:

$ gst-launch-1.0 filesrc location=/path/sample_720p.h264 ! h264parse ! avdec_h264 ! nveglglessink

$ gst-launch-1.0 filesrc location=/path/sample_720p.h264 ! h264parse ! nvv4l2decoder ! nveglglessink
Setting pipeline to PAUSED …
Pipeline is PREROLLING …
Got context from element ‘eglglessink0’: gst.egl.EGLDisplay=context, display=(GstEGLDisplay)NULL;
cuGraphicsGLRegisterBuffer failed with error(219) gst_eglglessink_cuda_init texture = 1
ERROR: from element /GstPipeline:pipeline0/GstH264Parse:h264parse0: Internal data stream error.
Additional debug info:
gstbaseparse.c(3634): gst_base_parse_loop (): /GstPipeline:pipeline0/GstH264Parse:h264parse0:
streaming stopped, reason not-negotiated (-4)
ERROR: pipeline doesn’t want to preroll.
Setting pipeline to NULL …
Freeing pipeline …

cuGraphicsGLRegisterBuffer failed with error(219) gst_eglglessink_cuda_init texture = 1

A100 is not display card, it’s compute card. you can try to setup virtual display, following Deepstream/FAQ - eLinux.org 5A, but it’s for Tesla series. you can give it a try.

Hello @amir7 Do you need further support? I think we can close the topic here.

Thanks,
is it possible to run the deepstream examples with this setup by letting the cpu handle the encoding part? If so could you point me to where I can see the code for it?

You can refer to deepstream-app, which support hardware encoder and software encode, you can set in config.
#encoder type 0=Hardware 1=Software
enc-type=1
create_encode_file_bin in sources/apps/apps-common/src/deepstream_sink_bin.c