[SOLVED] Trouble installing JetPack 3.3 for Jetson TX2 - Component Manager Error

Hello everyone,

I hope someone can help me with the following problem:

On an up-to date Ubuntu 16.04 LTS machine (no virtual machine) I have downloaded JetPack 3.3 and wanted to install it in order to install the SDKs on the host machine and update the Jetson TX2. But i did not get very far. I followed the steps of the official documentation: https://docs.nvidia.com/jetpack-l4t/index.html#jetpack/3.3/install.htm

The installation stops as soon as the component manager shows up. “Error” without further detail is written right above the progress bar. (See picture: https://image.ibb.co/jC1Ho9/Compnent_Manager_Error.png )
By the way: The dialog window which prompts admin access (step 5 of the documentation) did not show up.

Thanks in advance!

Update: I just checked the JetPack.log of the _installer folder and this is written there:

08-09 13:46:23.5 N: GoogleAnalytics disabled
08-09 13:46:23.5 E: fopen failed with file local.db, errno = 2

You may check this topic.

I have found that too and tried it, but it did not help. :(

FYI, the stage where components are listed will download some config files, and list via those downloaded files. So this tends to imply you have network issues. One example would be a proxy not set up, or perhaps a firewall.

Yupp. Exactly this was the problem, caused by the companies firewall. I used a proxy to solve this. Thanks!

I have exactly the same issue. But I am a bit confused since the same solution did not work for me. I have made proxy changes to the System Network settings (Manual) and the files in /etc/apt/apt.config and /etc/bash.bashrc.

Is there any other location where proxy changes have to be made?

I can’t say for sure, but the bottom line is that JetPack (or SDK Manager if using that) needs to be able to download the manifest files to know what the components are. If the installer application can’t reach those files (which are not necessarily going to standard web ports), then no components will be visible. Sorry, I don’t know which ports are used, but someone else may be able to tell you specific ports to be sure the proxy allows passing through.