Jetpack3 install hangs at Component Manager


I am trying to install the Jetpack3 on my Ubuntu 14.04 64bit workstation. I’m executing the run script as sudo and the install gets to the point of the Component Manager then just hangs with the bottom status indicator saying Downloading update lock. No packages are listed in the manager. After some long time it changes to Error and I have to close out the installer. The only files that are actually in the install folder are the _install folder and the JetPack_Uninstaller.

I had installed this Jetpack3 on this workstation for a TX1 board with zero problems. I have moved on to a TX2 and did a full uninstall of the initial Jetpack3 install to make way for a clean install for the Tx2.

Is this a common issue and if so is there a way to resolve it?


screenshot attached

You might try again when set for single-thread downloading:


(replace the JetPack file name with your version)

I tried the following and the install still hangs as described above.


Hi bruce4243,

Please download JetPack again and run on TX2.

chmod +x

Let us know your update. Thanks!

Is there something different about the Jetpack I will download today verses yesterday? If not I don’t expect different results.

Hi bruce4243,

Please try the latest JetPack3.1 release build.

thank you for the follow up, I have installed L4T directly from the packages and bypassed the Jetpack.

Any other updates on this? I have the same issue on multiple machines at my office, and find it easier to start out with jetpack installs. On my jetpack.log I get lots of:
08-07 15:33:43.1 E: Failure when receiving data from the peer

While Downloading the component manager. the downloading is getting restarted everytime.
Please help me with this

Which JetPack version? Is the Jetson used wired ethernet (WiFi on the Jetson during package stage is not supported)?

Hi arbzzml3h6,
Besides the JetPack version question from linuxdev, can you please let me know which file has the download issue? If it occurs to all files, can you please try the following steps?

  1. Remove all files in <JetPack_Dir>/jetpack_download/ directory.
  2. Select only “JetPack Documentation” component since it is small comparing to other components.
  3. Click “Next” button to start the download and install.
  4. Download will fail and then restart, after 3 times of failure, component manager will report download error.
  5. Please help upload the files in <JetPack_Dir>/jetpack_download/ directory to this forum.

Hi all,

I’m facing the same problem as described above.
This is my configuration:

Ubuntu 16.04.6 LTS and x86_64. running in Virtual Machine with Ethernet cable connected to Internet.

I’ve tried to install these Jetpack for the TX2:

And all of them are waiting “Downloading update lock” and then gives me an error.
What am i missing?
Can someone help me?
Thanks in advanced!

Sometimes VMs can be made to work, but they are not supported. There is usually some sort of loss of USB during certain USB re-enumeration events, and VMs won’t handle this correctly without special setup (I don’t know what the special setup is, but basically that device has to be owned by the VM no matter how often it disconnects/reconnects).

Hello linuxdev

Thanks for your answer, I will try to install it without a virtual machine.
On the other hand, I have some doubts about the connection between the Jetson Tx2 and the host.

To install the Jetpack, is it mandatory to have the Jetson connected to the host via microUSB/USB and Internet via Ethernet or Wi-Fi (preferably Ethernet)?
And then, the host, just connected to the internet through another Ethernet cable?

Thank you!

For the flash step the micro-B USB cable is mandatory. All flash occurs via this cable, and ethernet is not involved.

Once flash is complete the Jetson reboots. The micro-B USB cable can be removed for this step, but now networking is used and becomes mandatory.

Wired ethernet is the only kind of networking JetPack can configure. Other networking (WiFi) can work, but you would have to make sure it is set up prior to doing package install. “Working” implies you can ssh to the nvidia account. Sometimes WiFi isn’t the most reliable method even when it works, so wired is still preferred.

You can uncheck flash in JetPack and work with just package management at any time. Simply leave out the USB cable and use ethernet (and boot the Jetson normally without any use of recovery mode). If flash did not just occur, or if WiFi is to be used, then you must manually enter the IP address each time you run JetPack.

NOTE: The host must have internet access. There is no requirement for that to be wired or WiFi.

Hi linuxdev!

Thank you! The problem was in my internet network. For some reason, it doesn’t like the nvidia’s IP and with another network i was able to download and install all the packages!

Have a good day!