The Component Manager is empty on JetPack installation

HI,all

I need your help.
The Component Manager is empty on JetPack installation.Any box is unable and can’t select any Jetson target entries.
How to finish this installation of JetPack?
PS:The Linux Host belongs to corporate and can’t connect Internet.

Host Platform:
Linux ubuntu 14.04 x64
JetPack 3.1
Internet connection:invalid.

Thanks!!

Hi comlc, internet connection is required to properly run JetPack. JetPack will download the packages into the jetpack_downloads directory it creates under where JetPack was run from.

If internet connection is impossible for you, you can manually download and flash L4T from here: https://developer.nvidia.com/embedded/linux-tegra

Hi,dusty_nv
Thank you very much for your reply.
I have flashed rootfilesystem to internal eMMc,but no any components on target.
Can I install those components on target by manual installation,such as libcudnn,libopencv4tegra,libvisionworks? I have download those packages on host and target.

thanks!

Hi,

Please check this comment for manually executing JetPack:
https://devtalk.nvidia.com/default/topic/1023841/jetson-tk1/devicequery-fails-cuda-driver-version-is-insufficient/post/5208946/#5208946

You can download the package with the URL directly.
Thanks.

Hi,AastaLLL
Thanks for your reply.
I have installed all package.

Hi,

If I am facing similar problem, I have downloaded all the package and component manager is still empty. However, the launcher.log file shows that it cannot read my local.cfg

Thanks!

Hi,

Could you share the complete launcher.log?
Also, please remember to check the internet functionality.

Thanks.

Hi,

Here is my launcher.log

10-03 23:48::33.1 I: 0x6a 0x65 0x74 0x70 0x61 0x63 0x6b 0x5f 0x6e 0x65 0x74 0x77 0x6f 0x72 0x6b 0x5f 0x6c 0x61 0x79 0x6f 0x75 0x74 0x0a
10-04 00:14:47.0 I: 0x66 0x69 0x6e 0x69 0x73 0x68 0x65 0x64 0x0a
10-17 22:47:17.0 E: cannot read local.cfg

My computer is stand alone and has no access to internet

Hi,

Component Manager require internet access.

If the internet is not available in your environment, please install the package manually with the instruction shared in this comment:
https://devtalk.nvidia.com/default/topic/1023841/jetson-tk1/devicequery-fails-cuda-driver-version-is-insufficient/post/5208946/#5208946

Thanks.

HI
my laptop is running 14.04 and is connected to the internet via Wifi yet Jetpack appears empty. Looking for suggestions

Is the network connected correctly from the host? One of the download URLs for a package is this:
http://developer.download.nvidia.com/devzone/devcenter/mobile/jetpack_l4t/006/linux-x64/cuda-repo-l4t-8-0-local_8.0.34-1_arm64.deb

On the host, are you able to download this via:

wget http://developer.download.nvidia.com/devzone/devcenter/mobile/jetpack_l4t/006/linux-x64/cuda-repo-l4t-8-0-local_8.0.34-1_arm64.deb

Does this work:

ping developer.download.nvidia.com

If not, are you going through any proxy or firewall?

Hello,

I am facing similar issues.
I am able to download the deb file and also able my ping is working fine.

But, still my component manager is empty.
Any suggestion on this ?

Thanks.

Same problem for me.

Components Manager is empty. It was working before, got an error during installation, restarted the process and now I am not able to do it again.

@alessandro.piscioneri,

Same problem for me.
It was working before. Got error that could not download files and failed to work after that.

Hi,

Sorry for the late reply.
Does this issue still go on in your environment?

If yes, could you find any information shown the description windows?
Thanks.

Hi,
I’m having a similar issue. I’m connected to the Internet through a proxy, which seems correctly configured. My browser works fine, I was also able to ‘wget’ the .deb suggested by linuxdev
But when I launch the “JetPack-L4T-3.2-linux-x64_b196.run” script, I get an error window “The manifest file is broken.” And the components manager is empty. I already tried to remove all files, and re-download the script on nvidia.com, with no luck.
Any idea ?

Hello,

I was able to solve the issue.
The issue was my laptop had a static ip address.

Once I mad it automatic DHCP it started working.

Thanks.

Thanks for your feedback.
Good to know it works now. : )

Hi

I have same issue.
I installed ubuntu 16.04 in virtualbox. Use host briged network and DHCP is enabled.
And I can download the dep file, ping work.
Any idea?

$ ping developer.download.nvidia.com
PING cs5341561.wpc.phicdn.net (192.229.232.112) 56(84) bytes of data.
64 bytes from 192.229.232.112: icmp_seq=1 ttl=50 time=3.52 ms

Here is logs

loblue@~/work/jetpack/_installer$ cat JetPack.log
05-03 14:49:38.9 E: fopen failed with file local.db, errno = 2
05-03 14:50:17.3 E: fopen failed with file local.db, errno = 2

loblue@~/work/jetpack/_installer/logs$ cat jetpack_debug.log
PageAction: 2018. 05. 03. (목) 14:49:34 PDT: /home/loblue/work/jetpack/_installer/PageAction installation install . /home/loblue/work/jetpack Launcher 5472 /home/loblue/work/jetpack/jetpack_download
PageAction: 2018. 05. 03. (목) 14:49:38 PDT: /home/loblue/work/jetpack/_installer/PageAction installation miscellaneous . /home/loblue/work/jetpack Launcher 5472 /home/loblue/work/jetpack/jetpack_download
PageAction: 2018. 05. 03. (목) 14:50:13 PDT: /home/loblue/work/jetpack/_installer/PageAction installation install . /home/loblue/work/jetpack Launcher 5709 /home/loblue/work/jetpack/jetpack_download
PageAction: 2018. 05. 03. (목) 14:50:17 PDT: /home/loblue/work/jetpack/_installer/PageAction installation miscellaneous . /home/loblue/work/jetpack Launcher 5709 /home/loblue/work/jetpack/jetpack_download

The same issue and JetPack.log shows:
05-04 00:55:23.3 E: fopen failed with file local.db, errno = 2