some question about the SDK Manager

Hi guys,

I just download a SDK Manager-0.9.11.3405 and I have a membership to the nvidia developer .

Then I installed sdkmanager, started it.

I login in the DEVELOPER ZONE.

After a long time wait, then the Manager tell me that “No SDK is available for your account” ? what happened to me ?

How can I fix this ?

thx.
sdkm.log (25.9 KB)

Hi Zhangjiamin,

Thanks for trying SDK Manager! Does the issue still reproduce on your end?
Can you package the ~/.nvsdkm/ folder on your host and upload for us to investigate?

Thanks

Hi, changbins

reproduce it.

please see attachment.

Thanks.
nvsdkm.tar (5.99 KB)

Hi, changbins

reproduce it.

please see attachment.

Thanks.
nvsdkm.tar (5.99 KB)

Hi zhangjiamin,
From the log, it seems that a wrong version of configuration file was downloaded from the server. Are you located in China?

Can you check if there is a ‘Jetson’ item under https://developer.download.nvidia.com/sdkmanager/sdkm-config/main/sdkml1_repo.json? It will be great if you can also upload the file.

Thanks!

I encountered the same issue and there is no Jetson’ item in the downloaded sdkml1_repo.json file.

sdkml1_repo.json.zip (1.18 KB)

Yes, I am in China.

please see attachment of sdkml1_repo.json.

sdkml1_repo.rar (440 Bytes)

Hi there,
We are working to fix this issue. As a workaround, can you try to run the client with a different server address?
sdkmanager --server https://developer.download.nvidia.com/sdkmanager/sdkm-config-b/main/sdkml1_repo.json

Thanks

Thank you. I will try it.

Running sdkmanager without any command option should also work well now in China.
Please double check.

Thanks

Both ok.

Thank you.

Hi~I encountered the problem and still get no result. Would you please help me out?
I downloaded the latest sdkmanager deb file ‘sdkmanager_0.9.11-3405_amd64.deb’.
I installed it by ‘sudo apt install ./sdkmanager_0.9.11-3405_amd64.deb’
After login via ‘developer.nvidia.com’, I got the oops error ‘No sdks are available for your account’
I checked my membership information which shows as below: ‘nvidia developer program ID 874688’ and ‘accelerated computing developer program ID 873374’
I tried to login several time and reinstall the sdkmanager serveral times but still got the same error. Would you please help me out?

Or is there some offline installation package like jetpack 3.x I can get? Thanks.

Hi yanhnbupt,
Could you download the below URL on your end and upload in this thead?
https://developer.download.nvidia.com/sdkmanager/sdkm-config/main/sdkml1_repo.json

Are you also located in China?

Thanks

I checked the log file which says

error: sdkml1_repo.json download failed with error: ENOTFOUND, request url: https://developer.download.nvidia.com/sdkmanager/sdkm-config/main/sdkml1_repo.json

I checked the website url and could not get access to it.
When I used the flag --server ./sdkml1_repo.json the error changed to ‘oops! can not reach server configuration file’.
I am in China. Would you please give me some advice? Thanks.

Hi yanhnbupt,
Could you confirm that you were not able to access to https://developer.download.nvidia.com/sdkmanager/sdkm-config/main/sdkml1_repo.json through web browser, such as Chrome?

Could you also double check the network connectivity?

Thanks

Sadly, I can not access to https://developer.download.nvidia.com/sdkmanager/sdkm-config/main/sdkml1_repo.json.
I think it’s the dns problem that I cannot find the ip address of developer.download.nvidia.cn. There is a error code DNS_PROBE_FINISHED_NXDOMAIN.
The json file I used in my last post is from a friend of mine. He downloaded it for me.

Is there any off line installation package I can get? Thanks.

SDK Manager also supports to install the SDKs offline, please have a look at SDK Manager user guide:
https://docs.nvidia.com/sdk-manager/offline-install/index.html

But since the configuration file(sdkml1_repo.json for example) and software components are hosted remotely, you still have to download them once for the first time in a machine with network connection.

Thanks.
I changed the hosts file in /etc/hosts
My original hosts has only one line: 127.0.1.1. I changed it into 8.8.8.8 and can surpass the problem.