Sdkmanager - No SDKs are available for your account

SDK Manager fails at step one with a message that No SDKs are available for your account, and Failed to get configuration file from the server. I tried removing the .nvsdkm directory, as well as reinstalling the sdkmanager, and have tried connecting via different networks which all seem to have solid connectivity.
Please see attached
sdkm.log (142.5 KB)

Did you try logging in under the “developer” tab, or under the “partners” tab? Different logins for each, it is the “developer” tab for Jetsons for most people. Also, what version of Linux is running on your host PC? I’m assuming it is Ubuntu, but this limits which L4T releases are accessible (there are limitations beyond those of JetPack which change depending on host PC version of Ubuntu and Jetson model).

Yes, I log in under the “developer” tab, which is what I’ve always used. The host is running Ubuntu 20.04.6 LTS

Perhaps @TomNVIDIA can help on that one.

Hi @d.glass , this is a SDKM issue, unfortunately, I do not have access to that system. Let me see if I can get one of the engineers to assist.

11:10:51.741 - error: JETSON_TX1.json download failed with error ETIMEDOUT, request url: https:/developer.download.nvidia.com/sdkmanager/hw-config/HWDevices/Jetson/JETSON_TX1.json

The device json file download failed, seems to be a network or server issue.

1 Like

Was that URL a copy and paste? I see a URL error. What starts as “https:/developer...” should be “https://developer...”. Two “/”, not one. Also, if you simply point a web browser at:
https://developer.download.nvidia.com/sdkmanager/hw-config/HWDevices/Jetson/JETSON_TX1.json

…does that still time out? Or does something show up?

https:/ is just a string parse error in the log.
There are quite a lot of time out errors in the log. For the success downloads, it takes up to 37 seconds to download a simple JSON.

What about the URL I pasted above? Does anything make its way through?

Does this work?
ping developer.download.nvidia.com

If the above ping fails, then what is the output of:
traceroute developer.download.nvidia.com

What you are describing could be a problem at so many different locations or for so many reasons that something is needed to narrow it down. If you can use a browser to view that URL (which shows the json), then we know the route and DNS is working. Maybe there is a particular route hop which is problematic, maybe the router is slow, maybe there is some sort of caching issue. The above information would narrow the possible issue causes.

The URL to the JSON file works, without hesitation.
Pinging developer.download.nvidia.com also looks fine.
Traceroute has some timeouts.
The attached screenshots show the current situlation.



Traceroute hops which do not enable ICMP protocol won’t show anything, and so that isn’t necessarily a packet loss.

You have ruled out a route issue though since you can use a web browser to find the json file.

Someone from NVIDIA may be able to help (maybe @dusty_nv ?), but I’ll suggest that any old cache be removed. If you make sure sdkmanager is not running, then delete your “~/.nvsdkm/”, then try again, it might work.

Thank you. I’ve tried removing the ~/.nvsdkm/ directory, several times, with no improvement.

Bumping.
Still in the same situation.

Maybe @WayneWWW or @DaveYYY or @dusty_nv will see this.

Sorry for the late response.
Is this still an issue to support? Any result can be shared?