spread sprectum clock(SSC) related queries

Hi,

I’m using JetPack 3.3 for tx2i.

  1. is SSC enabled by default ??
  2. how to disable SSC & How to confirm the changes have been effected ?
  3. is there any way to disable SSC for pci clock ??

thank you

Can you tell us the version you are using? I mean r28.2.1 / r31 / r32 etc??
SSC is enabled by default. I can suggest you the method based on the version.

im using r28.2.1 ( JetPack 3.3)

please let me know

Hi,
In $TOP/platform/bpmp/ folder apply the following patch to disable Spread Spectrum for PCIe reference clock

diff --git a/tegra186-bpmp-quill.dtsi b/tegra186-bpmp-quill.dtsi
index 757923e233eb..e41b69aa63e4 100644
--- a/tegra186-bpmp-quill.dtsi
+++ b/tegra186-bpmp-quill.dtsi
@@ -14,3 +14,13 @@

 #include "tegra186-platforms/tegra186-quill-clock.dtsi"
 #include "tegra186-platforms/tegra186-quill-soctherm.dtsi"
+
+/ {
+       clocks {
+               clock@plle {
+                       clk-id = <TEGRA186_CLK_PLLE>;
+                       /* disable ssc on PLLE */
+                       pll_freq_table = <38400000 100000000 2 125 24 (-1) (-1) (-1) (-1)>;
+               };
+       };
+};

To confirm if it is indeed disabled, read the value at address 0x05043000 and in that, bit-12 should be ‘1’ (‘0’ means enabled)