SSH Through USB

Is it possible to connect by ssh to a PC using a USB connection, as it can be done with the Jetson Nano?

Yes, it is done quite often. Are you speaking of a Linux PC? If Windows, then there is a lot of pain involved trying to add an ssh server, but Linux is fairly painless. Usually it is a case of making sure the ssh daemon is running, and that security/firewall rules allow the incoming connection. A Jetson has a default of no firewall rules preventing the incoming connection, and this is the main difference between a Jetson ssh and PC ssh. Only needed if you wish to ssh from Jetson to PC; for PC to Jetson, no such setting change is needed.

If you are going through a router and one is inside and the other is outside (such as between private LAN and internet), then the router itself will require setup.

to connect to a PC though USB via ssh is possible if the conenction of the recovery usb-c port is conencted to the Host PC USB port, as it creates both at the Jetson and Host PC separate LAN interface with ip address for jetson; for Host PC So ssh could get through these
[ maybe the other usb-c port also will do, but I am using it wiith the recovery usb-c]

Thanks for your response. Is it necessary some configuration before doing that connection? I cannot find any LAN interface corresponding to the Jetson if I execute ifconfig while the USB is connected

typically it is autosetup so it wil be listed in outputs of
ip addr show

If security is enabled to not automatically just enable any USB device plugged in, then you’ll need to enable it. I don’t know about Windows, but if your host PC is Linux, then you might monitor “dmesg --follow” as you plug in the USB, and note the MAC address. If you see this, then you know the Jetson side has completed its requirements, and the next requirement is for the host PC to allow the device to be used.

In terms of allowing devices I tend to favor the GUI tool “nm-connection-editor”. If you don’t have this, then “sudo apt-get install network-manager-gnome” (there are other ways). Then add a connection based on that MAC address.

Every host may have differences in what is done when a USB device/router is attached, but the above should work for Linux hosts.

Thanks again for your responses, Reflashing the Jetpack worked and now the interface appears and I can connect through Also, flashing again solved a side issue where the ethernet connection wasn’t working