Startx command on JetsonTX2's tty mode yields the error: `/usr/lib/xorg/Xorg: error while loading shared libraries: libvrm.so`

Currently my Jetson TX2 development board will only boot to tty mode and not to the desktop GUI. Therefore to try start the desktop GUI I tried to run the command startx and that yielded the error message /usr/lib/xorg/Xorg: error while loading shared libraries: libvrm.so. This command did not start the desktop GUI and therefore I was wondering how you guys would recommend me to start the desktop GUI?

Hi,

I think the real question here is why you are lacking of this library. Are you sure you are running with pure software from jetpack?

I suggest adding this to the thread:

  • Serial console boot log.
  • /var/log/Xorg.0.log
    (assumes “ls -ltr /var/log/Xorg.*.log” shows Xorg.0.log as the last one, meaning most recently generated…sometimes the “0” differs, especially if you’ve used startx)
  • Output of “uname -r”.

I accidentally ran “sudo apt upgrade” to a new distro on the Jetson when I should have ran the jetpack’s updater and thus this error is now happening. So no it is not running pure software from jetpack because of that.

You may save a lot of time by reflashing your Jetson with an up to date JetPack version.

Note that this would wipe out any data or code developed so far on Jetson, so beforehand you would save your current work on Jetson into another storage so that you would be able to re-import later if any.

linuxdev what is and where do I find the “serial console boot log”? and “Xorg.*.log” when I did “ls -l” looks like it is not updated each time “startx” is run

I have tried reflashing my Jetson but am encountering errors in this post I made here: Flashing Jetson TX2 with the sdkmanager recognizing connection but not recognizing it is in forced recovery mode - #4 by eleehiga808.

Jetson dev kits (and almost all third party carrier boards) have a micro-OTG connector. If a micro-B USB cable is plugged into this, and the type-A end to the host PC, then a serial console program can be used to see what is basically a command line login. During boot, even before Linux runs, you’ll see boot progress messages. See:
https://jetsonhacks.com/2017/03/24/serial-console-nvidia-jetson-tx2/
(note that if you have the micro-B USB cable shipped with a Jetson that this is a high quality cable; charger cables often fail)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.