TX2 Boot Failed

Hi! I have some questions about my jetson tx2 and I was wondering if you guys could help me. Since yesterday, every time when I try to open my jetson tx2, the screen would show something like this

and just stop there, and I cannot get into graphical interface. I reboot it a lot of times and it’s still not working.

What can I do to fix this?

Hi,

Please check with serial console and see if system can boot up or not.
If it can, please share the log of /var/log /Xorg.0.log to us.

Yes, I can get into serial console and reboot, but how can I share my /var/log /Xorg.0.log?

Sorry…I’m so new to linux

Do you have etherent connect on your board? If so, use ifconfig to check the IP of your board, then you can transfer the data through scp command to other ubuntu host.

If you don’t have ubuntu host, then some tool like filezilla on Windows should also work.

If you are using Linux, then an example of scp to copy from user named “nvidia” follows (commands run from the host PC). Adjust for your login name and IP address (example is 192.168.55.1):

ssh nvidia@192.168.55.1 ls -ltr /var/log/Xorg.*
# You will see a list of files starting with "`Xorg.`", and the last one listed will be
# the one which is most recently changed. Assuming most recently changed is "`Xorg.0.log`",
# then this actually copies it to the host PC:
scp nvidia@192.168.55.1:/var/log/Xorg.0.log .
# Rename it with ".txt" for forum upload:
mv Xorg.0.log Xorg.0.txt

If you don’t know the address, then via serial console running “ifconfig eth0” should show it.

Hi,

thank you so much! Unfortunately I don’t have another Linux host, and I used Filezilla instead.

Thanks! Filezilla worked.

This is my Xorg.0.log
Xorg.0.txt (15.7 KB)

The xorg is still running. How about /var/log/syslog? Could you share it too?

Also, please use serial console to check if gdm3 is still running on device, no matter it is running or not, please restart it and see if desktop will show up or not.

Sure.

This is my syslog. syslog.zip (954.8 KB)

And I tried to run gdm-restart, it showed that command not found

-bash: gdm: command not found

Hi,

Have you ever reflashed your board before?

As for the gdm,

sudo systemctl stop gdm
sudo systemctl start gdm

Yes, my colleague reflashed it once, and he doesn’t work here anymore. So I don’t know much details.

It showed

Failed to stop gdm.service: Unit gdm.service not loaded

Same with start gdm.

Hi

What is the result of

sudo service gdm status
sudo service gdm3 status

Hi

It showed this

Also, are you sure your disk space is still enough? We once had similar but it is due to insufficient disk space.

Yes, the disk space looks okay

Ok. Could you try to reflash the board?

Yes, that’s what I thought…but I’m still learning how to reflash the board, it might take some time