The error message "System throttling due to over-current" appears when running YOLOv4

I’m getting Server Error (500) after login ?

(Can anybody confirm Sign In link actually works?)

Hi JerryChang,

How can I turn off this warning message?

hello sam.tsai,

it’s suggested to create a customize power modes, by reducing CPU/GPU frequencies to reduce power consumption of nvpmodel.

hello pev,

could you please try again, you should have forum account to access the tool.
please check the Tutorials | NVIDIA Developer, here’s training video, Getting started with new PowerEstimator tool for Jetson for your reference.
thanks

I do have forum account which is working OK (can login to this forum) but i still get Server Error when i try to log in to access the powerestimator tool… is there any other place i could get the tool ?

I tried using the tool as well, i can login in fine but adjusting the parameters and pressing estimate power does nothing. No estimated number shows and no download option shows for the config. Am i missing something?

You mean there was problem to login the developer site:Autonomous Machines | NVIDIA Developer ?
Supposed the user name and password are the same, could you try again?

I have the same condition here, I can login forum, but PoserEstimator still have 500 server error. Is there any other way to test this tool?

I used another login and i have been able to log in a couple of times… sometimes i get error although its not 500 server error…

About the tool as amr_elgendy said… Estimate Power button does nothing… no wattage or any value(s)… always just that same red Power rectangle…has anybody actually got this working ?

I doubt may be some network glitch browser specific issue. Although we have handled almost all browsers but for better experience please try with Chrome browser to see it issue still present.

And, please be sure to Logout and login again.

Thanks

I am still getting this issue.

I’ve tried to measure the power usage as well

JetPack 4.4: 12V 2.0A
JetPack 4.5.1: 12V 1.5A

It seems that 4.5.1 the current is being limited, even though i’ve set OC limit to 5A. I am not sure if the OC change is being accepted by the system or not. But I cannot get beyond 1.5A usage in 4.5.1, which is easily achievable in 4.4.

Is there any other way to force the current limit to 5000mA ?

When i tried to add the OC limit to 5000mA in the startup script and rebooted, after that using the system for sometime it froze on the nvidia logo with weird checkerboard pattern all over the screen, in short it was a brick. I had to reflash the whole system.

The main question is, everything works fine in 4.4 but not on 4.5.1, so there must be some fix for this.

1 Like

@sam.tsai were you able to solve this issue ?
I am also working on YOLOV4 with heavy usage, and i get system throttled message on JetPack 4.5.1, but not on JetPack 4.4.

Hi,
I still can’t solve this issue on JetPack 4.5, as you said, it is pass on Jetpack 4.4.
Nvidia did not give a truly effective solution on JetPack 4.5, so I will skip this issue for first.

Need to make some clarifications for this issue.

  1. The OC throttling case also appears in jetpack4.4.1. The real cause that makes you feel this issue does not happen on jp4.4.1 is because there was no “OC alarm notification” mechanism implemented in jp4.4.1. Thus, jp4.5 and jp4.4.1 actually both have oc throtting.

  2. The oc throtting is due the the hardware limitation of NX module. We currently set OC limit to 3.6A to protect the NX hardware.

  3. The suggestion to prevent the OC throtting notification are:

  • Set the OC limit to 5A. This shall still improve the performance and still not do harm to the module.
  • Use the power estimator to adjust the nvpmodel conf. The throttling may not happen, but the performance may drop.
1 Like

Hey thanks, i have yet to try to power estimator, will get back after that.

  1. “The real cause that makes you feel this issue does not happen on jp4.4.1 is because there was no “OC alarm notification” mechanism implemented in jp4.4.1” - yes okay, that definitely makes sense then.

My issue is that in JP4.4 running deepstream YOLOV4 model, i was able to get 16FPS on both camera streams of 4K without any issues, but on JP4.5.1 one of the camera just goes blank and the other camera source is about 8 FPS. this happened even after setting the OC limit.

This is on JP4.5.1

I’ve checked the same configuration file works on JP4.4, so now i am not sure what could be the problem.

I can’t share the config file because we are using a custom plugin which also does a lot of processing.

On your jetpack 4.4.1, please check

/sys/kernel/debug/bpmp/debug/soctherm/oc# cat oc_1/event_cnt
/sys/kernel/debug/bpmp/debug/soctherm/oc# cat oc_1/irq_cnt

This will record the oc event. We can compare the event cnt between jp4.4.1 and jp4.5.1 with same application running.

1 Like

@WayneWWW

Hi, we did some testing, The following numbers are after running our application for sometime, ~10 mins

On JP 4.5.1

$ sudo cat /sys/kernel/debug/bpmp/debug/soctherm/oc/oc_1/event_cnt
>> 3099

$ sudo cat /sys/kernel/debug/bpmp/debug/soctherm/oc/oc_1/irq_cnt
>> 1548

On JP 4.4

$ sudo cat /sys/kernel/debug/bpmp/debug/soctherm/oc/oc_1/event_cnt
>> 3601

$ sudo cat /sys/kernel/debug/bpmp/debug/soctherm/oc/oc_1/irq_cnt
>> 1780

I have some good news, I set the OC limit to 7000 mA instead of 5000mA on JP 4.5.1, and the warning disappeared ! i was a little worried, since i am getting it out of specs, so we tested it for an hour, with no issues, we observed better sync between the frames of the two cameras as well !

And no more issues with the camera as well ! it turns out i had set sync-inputs=true for the nvstreammux which caused one of the camera to black out, it was never the power issue, this sync-inputs thing is only there on JP 4.5.1.

I believe there are some issue with synchronizing frames between two cameras in nvstreammux using sync-inputs=true, expected behaviour should be despite different fps of cameras, it should still be able to synchronize the two cameras.

Just to add another report:
I am using a pose estimation network in OpenCV (compiled with CUDA support) decoding a RTSP video stream (h264 decoding with hardware accelerated ffmpeg backend). CPU is at about medium load.

I applied the OC limit setting for 5000 ma. In 15W / 6 cores power mode I get the over-current throttling warning as well. Attached to the board is a RasPi HQ camera bit it is not used in that case. A monitor is connected to the HDMI port.

Hi @helge ,

Can you file your own topic and paste the your power estimator result so that we can check what is going on?