The Nucleus service appears to be unresponsive


after opening Omniverse Launcher I keep getting this error message:

I am using Ubuntu 20.04.3 and a local Nucleus Server 2021 3.2.
It was working yesterday without a problem. Today I updated Isaac Sim to version 2.1 and it stopped working (I’m not sure if it’s related).

If I go to localhost:3080 I get the error “Cannot connect to System Monitor Backend”

I tried uninstalling and installing nucleus again but it did not help. Here are my logs from /.nvidia-omniverse/logs and /.nvidia-omniverse/logs/Nucleus: (494.7 KB)

Can you help me solve this issue? And in the meantime, is there a quick way to recover the Projects that I had stored in my Nucleus /Projects folder?

1 Like

Hi @jominga , and thank you for joining the community forum! I see a similar thread on this error here: Cannot connect to System Monitor Backend - #18 by dduka

Can you try some of the suggestions outlined in the thread…if that does not help, we’ll probably need to look at your files, but let me know.

Regarding recovering project files, are you using Drive (Drive Connect — Omniverse Utilities documentation)?


P.S. We are constantly adding new tutorials and aggregate them all in the “learn” tab on the launcher (also see:

he / him | LinkedIn | Discord ID: Prof E#2041
Omniverse: “A New Era of Collaboration and Simulation” (video)
Omniverse Create’s latest features show & tell: Twitch livestream.
As seen in VentureBeat | Physics Showcase

Omniverse Resources:
Open Beta | Documentation | Tech Requirements | Videos | Roadmap | Twitter | Discord | Twitch

PLEASE NOTE: If you are reporting a bug/issue, please provide OS, GPU, GPU Driver, the version of the app, and full log file (if applicable). For crashes, please zip and provide a link to your logs → C:\Users\ [YOUR NAME] \ .nvidia-omniverse\logs

Hello @emendizabal, thanks for your response.

I came across that thread before posting my message but the suggestions there did not help (I could not find any ports.toml file in my omniverse folder).

I am using Ubuntu, so Drive is not an option for now, since it is only compatible with Windows.

Let me know exactly what files other than the ones I already posted could help figure out what’s wrong and I’ll upload them.

Thanks in advance!

Hello @jominga. I passed along your log files to the development team to get some feedback from them.

Meanwhile, I took peek at your log files and found 2 errors that stood out to me:

Failed to lstat the base path “/home/USERNAME/.local/share/ov/pkg/nucleus-workstation-2021.3.2” for component nucleus-workstation@2021.3.2 Error: ENOENT: no such file or directory, lstat ‘/home/USERNAME/.local/share/ov/pkg/nucleus-workstation-2021.3.2’

(node:22165) electron: The default of contextIsolation is deprecated and will be changing from false to true in a future release of Electron. See [Discussion] Changing the defaults for nodeIntegration and contextIsolation to improve the default security posture of Electron applications · Issue #23506 · electron/electron · GitHub for more information

Here are a couple of things you can try that have worked for other users. Let me know if you have already tried them.

Do you have a default Browser (like Chrome) set on your computer? If not, set one up so that Nucleus has a way to access the internet, then try to log in again.

  1. Uninstall Cache
  2. Download Nucleus from NVIDIA Isaac Sim - Getting Started | NVIDIA Developer
  3. Try to install Nucleus on Omniverse launcher then it’s download setup folder in “~/.local/share/ov/pkg/nucleus-workstation-2021.2.4/”
  4. Extract and paste on “~/.local/share/ov/pkg/nucleus-workstation-2021.2.4/” the downloaded nucleus zip (step 2) file except setup folder.
  5. And try to install nucleus again.
  6. Reinstall Cache.

Also, please take a look at our Linux Troubleshooting doc here: Linux Troubleshooting — Omniverse Nucleus documentation

1 Like

Hallo WendyGram,

I ended up reinstalling all Omniverse from scratch and now it works.

Thank you!

I’m getting something a bit similar here. Nucleus is looking like this:

and I can’t click on the ‘add local nucleus service’ button. A little history with this one. Omniverse was up and running. I had noticed an option to update Nucleus the other day and did not notice the outage warning. The update started, but never completed and I lost access to my local service. I tried to uninstall and re-install the launcher which ran fine (it must have found aspects of my previous install as I did not have to re-install create/view/connectors/etc), but it did not restore Nucleus to a running state.
Is there any way I can forcibly re-install Nucleus (e.g. remove some files and re-run the launcher install)?

note: I ran the cleanup tool and re-installed and I get the same problem. In the launcher logs, I see:

[2022-03-02 09:34:29.936] [info] Requesting the feature list for en…
[2022-03-02 09:34:29.968] [info] Enabled features for en: { bugReports: false }
[2022-03-02 09:34:32.297] [debug] Failed to connect to the discovery service using port-based routing (ws://localhost:3333): { isTrusted: true }
[2022-03-02 09:34:37.159] [debug] Failed to connect to the discovery service using port-based routing (ws://localhost:3333): { isTrusted: true }
[2022-03-02 09:34:42.031] [debug] Failed to connect to the discovery service using port-based routing (ws://localhost:3333): { isTrusted: true }
[2022-03-02 09:34:42.033] [info] Couldn’t find the port for Web: Error: Failed to connect to the discovery service localhost
at qt._connect (file:///C:/Users/rjfrank/AppData/Local/Programs/omniverse-launcher/resources/app.asar/dist/renderer/js/connections-page.ef41a12c8c129e5740fd.js:1:66444)
at async qt.find (file:///C:/Users/rjfrank/AppData/Local/Programs/omniverse-launcher/resources/app.asar/dist/renderer/js/connections-page.ef41a12c8c129e5740fd.js:1:65552)
at async file:///C:/Users/rjfrank/AppData/Local/Programs/omniverse-launcher/resources/app.asar/dist/renderer/js/connections-page.ef41a12c8c129e5740fd.js:1:77655
at async file:///C:/Users/rjfrank/AppData/Local/Programs/omniverse-launcher/resources/app.asar/dist/renderer/js/connections-page.ef41a12c8c129e5740fd.js:1:77540
at async Ma.findPort (file:///C:/Users/rjfrank/AppData/Local/Programs/omniverse-launcher/resources/app.asar/dist/renderer/js/connections-page.ef41a12c8c129e5740fd.js:1:77438)
at async Ma.load (file:///C:/Users/rjfrank/AppData/Local/Programs/omniverse-launcher/resources/app.asar/dist/renderer/js/connections-page.ef41a12c8c129e5740fd.js:1:77231)
[2022-03-02 09:34:42.035] [info] Using the default web port 8080.
[2022-03-02 09:36:46.740] [warn] Couldn’t load featured components: Error: Featured components are not available – HTTP403.
at S (file:///C:/Users/rjfrank/AppData/Local/Programs/omniverse-launcher/resources/app.asar/dist/renderer/js/main.ef41a12c8c129e5740fd.js:1:53331)
at async Object.queryFn (file:///C:/Users/rjfrank/AppData/Local/Programs/omniverse-launcher/resources/app.asar/dist/renderer/js/exchange-search-page.ef41a12c8c129e5740fd.js:1:14164)
[2022-03-02 09:36:50.791] [warn] Couldn’t load featured components: Error: Featured components are not available – HTTP403.
at S (file:///C:/Users/rjfrank/AppData/Local/Programs/omniverse-launcher/resources/app.asar/dist/renderer/js/main.ef41a12c8c129e5740fd.js:1:53331)
at async Object.queryFn (file:///C:/Users/rjfrank/AppData/Local/Programs/omniverse-launcher/resources/app.asar/dist/renderer/js/exchange-search-page.ef41a12c8c129e5740fd.js:1:14164)
[2022-03-02 09:38:29.804] [warn] Couldn’t load featured components: Error: Featured components are not available – HTTP403.
at S (file:///C:/Users/rjfrank/AppData/Local/Programs/omniverse-launcher/resources/app.asar/dist/renderer/js/main.ef41a12c8c129e5740fd.js:1:53331)
at async Object.queryFn (file:///C:/Users/rjfrank/AppData/Local/Programs/omniverse-launcher/resources/app.asar/dist/renderer/js/exchange-search-page.ef41a12c8c129e5740fd.js:1:14164)



I’m having the same issue as @randy.frank. Any advice?

Same here… can’t install nucleus workstation or enterprise

Same as @randy.frank.
Any update on it?

Its’ three days and Local Nucleus Service is still not working

Same issue about two days. Any comments? Does it have relationship with omni-outages?

Same issue with @randy.frank
It’s been quite a few days, any chance to fix the issue?

Same Issue Here. It’s been a long time for this.

Nucleus is working for me right now… Have not spent a lot of time testing, but I was able to create a new service, etc. My install basically fixed itself this morning and I am running again. Thanks!

Uploading: 오류1.png…
I tried all methods, but it doesn’t work. I don’t know why these errors are neglected.

ConnectionError: Interface ‘Connection’ from ‘omni1.idl.ts’ has not been found.
System Monitor222.log (24.0 KB)

  • Cannot establish connection to the server ws://
    This error message pops up and the connection cannot be established.