Transfer Shape Data in Blender Plugin not working

I’m going through the process of importing an animation from Audio2Face to Blender. “Import Rig File” button works perfectly. I see a new collection titled “A2F Import” in the outliner and the mesh data under this collection has all the shape keys from Audio2Face. Then when I click “Transfer Shape Data” I get a message at the bottom of Blender’s window saying “Transferred 0 Total Shapes”. I’m doing everything identical to the video tutorial but it still won’t transfer the shape keys. Everything up to this point in Audio2Face has worked perfectly. I can even still move forward and import the animation clip which controls all the shape keys great. I just can’t get the shape keys transferred to the right mesh. Hope I’m just making a stupid mistake. It wouldn’t be the first time! Thanks!

@woodlanddave i am just another user passing by, which tutorial(s) were you referring?

Omniverse audio2face and blender part 2. Thanks for the reply!

a few more inquiries:

  • is it possible for you to disclose about the versions of Blender and A2F apps you are using?
  • to confirm, everything works in A2F and only when bringing it back into Blender is when you notice the issue, correct?
  • was there any error in the A2F console during/right after export?

I’m using omniverse’s version of Blender 4.0.0. Audio2Face is 2023.2 version.

Yes I think everything is working in Audio2Face but the issue occurs in Blender.

I do get a whole slew of warnings in the console but no errors.

Maybe there are some errors actually. I’m having trouble understanding what the console is saying. The displayed console seems a bit different than the log file. I uploaded the log file from today. I exported the blendshape generation data 3 times (while trying figure out where the log started for this function) so I believe it only has that info.

kit_20231222_101311.log (907.0 KB)

This might be because of the space in your username. Can you try installing Launcher and all apps in a user without any special characters?

@Ehsan.HM I tried your suggestion and it still doesn’t work. I still get a bunch of warnings as I go through the process of setting up the character in A2F but everything still works so well except this step.

When you exported the BlendShapes from Audio2Face, 2 files got created on disc, one of which ends with _usdSkel.usd. Can you open this file in a Audio2Face to see if it has all the blendShapes.

If yes, this means everything worked on Audio2Face side, but Blender couldn’t import them properly.

I opened the file in A2F as you said and it appeared to have worked. However the names of the blend shapes are different than the ones in your example picture.

Can you send a screenshot of the blendShape names?

I’ve done a lot more troubleshooting today and can confirm that everything works fine except the “transfer shape data” button in the A2F plugin. The step right before this is “import rig file” and this creates a new mesh copy of the head from A2F in Blender with all the shape keys. When exporting the blend shape solver from A2F, it applies the animation to this mesh head copy. It plays the animation great in blender on the copied head. My issue is just that I can’t get the data transferred back to the original mesh.

Those shapes seem to be NV46, but I think Blender needs ArKit shapes.
When generating blendShapes, can you choose 52 ARKit Poses to see if it works?

It was really suspenseful giving this a try! Unfortunately I still got the same result. The shape keys were the same as yours in the screen shot you posted a while back. Thanks for all this help! I’m going to keep trying new things for a while.

Oh, sorry it didn’t help. I know you’ve seen these tutorials, but it might be worth watching them again and see if you’re doing something different.

Omniverse Audio2Face and Blender | Part 1: Generating Facial Shape Keys (
Omniverse Audio2Face and Blender | Part 2: Loading AI-Generated Lip Sync Clips (

Will do! Thanks Ehsan! For the time being I found a work around that maybe could help others in my position.

When you import the shape keys from the usdskel.usd file it creates a mesh copy of your original exported head with all the shape keys assigned to it. I didn’t see it at first because it was rotated 90 degrees down on the X with it’s origin between my characters feet. So just rotate it back to your character and delete your original head. In my case the faces needed to be deleted were already selected in edit mode when I did the face prep part of the process. Then you can just join the new head with the body object. If your body and head use one UV map like mine did, then make sure they have the same name. This way when you combine them to one object the materials are applied to the new head properly. Also my character wasn’t rigged yet so I don’t know what affect this would have on the rig.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.