Trouble getting Cuda working on TX2

I’m having trouble flashing my TX2. I believe its the network connection part of the installer because they either freeze at “Cannot detect IP address of target” or it closes and prompts a complete.

I have tried all possible variations and on some configs, it screws up my network. Renders the networking functions useless on Ubuntu 16.04 host PC. Had to do some rfkill, edit the /etc/network/interfaces and if up/ifdown to get it working again.

To reduce ambiguity, I have tried using ethernet cable on both host and target and chose the enp2s0 option for both, but it failed too.

As a result, I could get cuda working on my target TX2. Would appreciate someone sharing the correct setup for the networking step for the installer and any workarounds for similar problems faced.

FYI, my host does not have any discrete GPUs ( if it matters )

FYI, after a flash via JetPack the TX2 will automatically reboot, and the first reboot includes methods to try to auto detect the address. After that first reboot the mechanism won’t work. You can run JetPack at any later date, uncheck flash, and just add packages. So if this is the case for you, and the Jetson was not just flashed and on its first automatic reboot, then the address needs to be entered manually.

The first thing you will want to do is to just log in to the TX2 and see what its address is (log in at any local terminal or serial console). Run “ifconfig” and see what eth0 has for address. Then try to manually ssh to that address from your host PC. For example, if it is “”, from the host try to log in to the “nvidia” account via both of these:

ssh nvidia@
sudo ssh nvidia@

You might be asked if you trust the connection…just say yes. This might be the part causing the Jetson itself to not connect. Once ssh works, then you can use JetPack.

Are you able to determine the address from a Jetson login? Are you able to ssh to the nvidia account on the host PC?


Usually, JetPack use ethernet to flash OS and internet to install packages.

Does your device connect to a network?
If the JetPack installer cannot detect the IP of your device, could you type it manually?
(Check $ifconfig on the device and type the IP information to installer.)