Two jetson nano make ad-hoc network too slow but power_save can't off

hello everyone
when I set jetson nano network ad-adhoc as WiFi/AdHoc - Debian Wiki
but wlan0 power_save is always on,can’t set power_save off. so ping A to B is 100+ms,I want to ask help to solve this problem .

You can try with iwconfig wlan0 power off to turn off the power save mode.

note it only effect one time and be enabled and recovered after reboot.

Thank you for your answer. but it can’t solve this porblem.
I put the config of /etc/networking/interfaces and terminal result as pictures, Please have a look ,Anyway,Thank you for your answer!!!