TX1 boot to command line

Is there an easy way to set up my TX1 to boot directly to the command line instead of the GUI? I’ve tried both suggestions listed in the thread below, but neither has worked. I’m running R24.2.1.


I can confirm on R24.2.1 that both “systemd.unit=multi-user.target” and “text” added to extlinux.conf APPEND no longer work to go to text mode. These should also work, but do not:

# To default to text mode:
sudo systemctl enable multi-user.target
sudo systemctl set-default multi-user.target
# To manually go to text mode:
sudo systemctl isolate multi-user.target

I’ve tried editing “/etc/init/rc-sysinit.conf”, this too is ignored.

I have to conclude that neither old style nor systemd style changes work…this may be a genuine bug. If not, then something has changed drastically to ignore both the old init style and systemd as well.