TX2 will not boot after CTI flash.Bricked!

Hi all:
I have been using TX1 with the Orbitty carrier from Connecttech. They work nice but you need to flash their files to use the board. Recently I got a TX2 to handle the zed camera and I flashed jetpack 3.0, got all the CUDA running and the zed camera working fine.

For a production system I need to use the Orbitty carrier so I flashed their files for the TX2 as per their website. I used flash.sh as they recommended and the the procedure ended with flash successful. BUT the TX2 refuses to boot. No output on HDMI. No ethernet. I have not tried serial console on UART0 but I will tomorrow. How do I recover this thing ? I looked at all the web discussion - my files are fine I do not have the 64bit nonsense in the mke2fs.conf file that some of you asked to be deleted. I am kinda pissed because the TX2 was working so nicely on the dev board and now it is just an expensive fan !

Any ideas appreciated.

hello DrWino,

may i know are you able to enter forced-recovery mode by pressing the REC and RST hardware button?

Yes. I can get into forced recovery and I can verify that I have a connection by lsusb

Since lsusb shows the device it is very likely the hardware is completely unharmed (it isn’t bricked, it just doesn’t have the right software). You can always flash again, and if the software used for flash is valid for that carrier board, then it should work. Each carrier board though does have very different board support package requirements…so you’d have to be sure you have the right software for that board.

If interested in testing, then you could put the module back on a dev board and flash with the usual Jetson software.

If you can’t see a DHCP request going out, and ping does not work, a serial console would be of extreme value to see where things have gone wrong. As to whether the right software was used for that carrier I have no idea…I do not have an Orbitty carrier board so I don’t know what they require.

Thanks all. I put it back on the dev board and rebuilt Jetpack 3.1. Then reflashed just the OS. YES Got ethernet connection. So the TX2 is still live. Talked to the folks that build the orbitty carrier and it turns out that the in flash.sh must set to the board type. In this case orbitty. So I ran their install script then reflashed the TX2 and the serial monitor, ethernet, USB ports came to life and the HDMI works. There were some spurous /apt/list locks that I deleted and back in business.