UART1(/dev/ttyTHS0) of Xavier NX, TX does not work

i had same issue like this topic .

i am using l4t version 35.1

when i try to find detail of how to solve this.

the document i can find about of how to modify device tree, they all base on previous version of l4t like version 32.

like this

i had download Driver Package (BSP) Sources

but i cant found specified device tree configuration file

l4t 34.1.1 download page

the under below is l4t 35 and where i downloaded bsp code, did i download wrong source code?

Please flash to Jetpack 5.1 or 5.1.1 through SDKManager. And after booting, please run to enable the UART port:

$ sudo /opt/nvidia/jetson-io/

And save the device tree, reboot the system. After rebooting, the pins shall be configured as UART port.

thanks for reply.

my default pin config like below

is my config right?

my jetson version is

now uart1 can communicate will pc with usb dongle in 115200 baud rate.

but it still can not communicate with flight controller(ardunio like device, usb-uart dongle works). do i need some pull-up or pull-down resistor to make it works?


blue chart is Xavier NX UART1 RX signal

yellow chart is Xavier NX UART1 TX signal

maybe this is the reason why my controller can not receive Xavier NX board data?

If it works with communicating to PC, the device tree should be good. For communicating with the flight controller, are you able to try other baud rate?

I am curious about something…what does the signal look like if the Jetson communicates with itself on that UART port in loopback mode? Connect TX to RX, and if using flow control, then connect CTS to RTS. Do you see delays in TX->RX like in the image you posted above? If not, then you might describe your cabling. I noticed a lot of noise in the yellow TX (which would be the other end’s RX).

Yes, i tried 921600 and 9600, no luck, all the baud rate above can not work.

Thanks for reply.

I tried lookback mode in baud rate 115200. signal is good(no delay) and i can receive data in jetson.

the cable of connecting flight controller and jetson board is similar as lookback cable.

That cable is unshielded, so quite possibly this would contribute to noise (not so much of a worry at 9600, but a problem at 115200, and definitely an issue at 921600). What is the source of noise in the yellow TX signal of post #9?

Incidentally, do the Jetson and other unit have a good common ground? At the moment of applying a test instrument which has a ground the test instrument itself might introduce a ground loop. Is this a drone whereby attaching the serial console might change the ground connection, or even attaching the oscilloscope might change grounding? There’s lots of information on the internet on ground loops, but I like the schematic illustration in this (the schematic notes the difference between a common with one ground versus several grounds which are otherwise not common):

Notice that your UART on the Jetson has to share a ground to some other system except when loopback has the UART talk to itself; however, adding the oscilloscope itself adds another ground. Do you see that noise in loopback on the Jetson? If not, then it is safe to conclude that the TX/RX/Ground on the Jetson is ok by itself. Similarly if the UART of the remote device is without noise in loopback mode. If the noise occurs only when the two units connect together, then you might have a ground loop (or at least a low quality common, or both).

This does not say that this is not a software issue, but until you figure out the noise I wouldn’t bet on a pure software solution. I’ll suggest shielded cable and considering if you have a ground loop issue.

Thanks again

I will try to exam the ground loop and try to shield cable.

Also, I bought 2 more other vendor’s carrier board and i will try some cross examination.

I’m very appreciate for your help.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.