Ubuntu 22.04 image beta test for jetson nano

Hello I am creating an ubuntu 22.04 image the base is from A02 4GB devkit but will work too B01 and 2GB devkit.
With many current development libraries already installed
I have opted to put Ubuntu budgie for the desktop and a minimalist desktop.

with some applet for notifications and calendary with Sound HDMI/analogic options.
Flatplak gpu aceleration are enabled
Chromium up to with aceleration enabled webgl working .
Firefox up to 113.0.1
L4T-scripts for automatic compile and some specific tegra stuff .
Terminal is tilix can support multi windowed integration .
By default the compiler is gcc 7 for compile the kernel and cuda 10 stuff but also have gcc9/gcc11 and clang-14 are installed

User : aresuser
Password thera
Minimal sdcard 64GB
Download http://jetson-nano.freeddns.org:6210/jetson_nano/ubuntu2204.img.xz


Nice! Thanks for your sharing to the community!

@_Diablo : You are not really collaborating with me. But your idea started by me or anyway,it was stalled,I have given to it a very good impulse. It looks like you made it your own exclusive ; but anyway,we are having a discussion on this argument,we are sharing ideas and opinions. I think that your behavior hasn’t been polite. Not to mention the fact that usually people who shares their knowledge reaches a better result. You’d better to learn what it really means to work together,to make a team. In addition,from what I read,you have offered to users an image where the gpu of the jetson nano does not fully work. So,I think that it would have been better if you waited to solve the main problem before to offer your image. You didn’t even mention me : something like “thanks to marietto2008 for”. you know,I have worked hard to figure out how to enable some features specially for ubuntu 22.04.

hmm? I don’t know why you get like that if I’ve been using ubuntu 22.04 for a long time Ubuntu 22.04 by my research with colab switchroot helped a lot in some stuff i.e flatpak acceleration , L4T-scripts…
I have it testing since BSP 32.6.x image exists

Until now I had enough ubuntu focal has become obsolete in how much dependencies and packages (if you don’t throw several external ppa packages compared with jammy 22.04).

But I’ve been testing ubuntu 22.04 without problems for a long time.
And the GPU is fully functional, there is no break here.
Vulkan work,
GPU cuda 10 work,
OpenGL, OpenGL ES working.
X11 working

And I have posted it for better feedback since I don’t have an nvidia jetson nano B revision only 2GB and A02 version.

For 2GB users, if you get the overvoltage popup problem message, users have reported to me that it can be solved using a 5.3V power supply.
For some reason at higher load 5V they are not stable.
I will also raise the swap to 4GB by default since it may complain about low memory warning in some strong cases.

yeah,ok,but this does not “remove” my contribution and I think that OUR discussion produced a more knowledge or awareness about what to do to produce a fully working ubuntu 22.04 ubuntu system. You seem to don’t recognize my contribution, even if only in the form of suggestions and ideas. Apart from this, mine is an invitation to be included in the project, because I share it, because I have helped and because I would like to continue doing so. Above all because you still haven’t managed to get CUDA 11 or 12 working and for this reason you could have waited before providing the image. I also think that we can reach the result if we can collaborate. The real value of the image in my opionion is to add the support for CUDA 11 or 12,because the other features are less important and can be achieved without a special knowledge and efforts. On internet there are already a couple of tutorials that teach how to produce an image like your. I could have produced the same image as you,but I didn’t so,thinking that I wasn’t going to create anything really new. So,I don’t understand the reasons for your hasty choice or your lack of desire to collaborate with me too.

At no time did I say that I do not recognize your possible ideas or suggestions.
I tried to edit the first post but it won’t let me edit it.
I have made little progress with the installation of cuda11 it in jetson nano I have forced the installation to the 32.5.x packages but no example works cudaErrorUnknown error 999.
It is probably due to differences in the kernel and compatible structure with older drivers.

New few image oriented for Retro emulation and small stuff.

http://jetson-nano.freeddns.org:6210/jetson_nano/ubuntu2204.img.xz = unable to connect

Try again It seems that the router had been hung up.

It’s downloading. ok. Do you have the jetson orin,also ? I would make some experiment between the nano and the orin,but I don’t have orin. I nice idea would be if you keep it running with an ssh account active for me,so I can login and grab the files I need to make my experiments. I will not modify your board,since I want only modify my ubuntu running on my nano.

Sorry but i don’t have orin devkit
In my area for now the price up to $600/€600 the orin basic 8GB devkit version
In the future ? Possibly but when prices have stabilized a bit.

You can buy online the jetson Orin nano 4 GB for 242 Euros. Is it expensive for you ?

It’s the module only .
The devkit i’ts from 8GB version.

I think that my jetson nano is broken. I can’t conduct more experiments. I don’t have the money to buy a new one. If you want collaborate with me,I have several ideas in my mind to still try to enable cuda 11. But without my board I can’t do anything. If you want help me,you could keep your board online creating an ssh account for me. I will join and I will explain to you what I want to try before to try. We could collaborate. Let me know.

Going to test the latest image to base from and combine what I have working (if there is anything to add.) It really would be great if we had somewhere to build something more sustainable to support these devices. Looks to me the Armbian images are lost in space somewhere. I don’t know how working those are or even if they are maintained.

Slightly concerned, was using any of these images what caused the breakage? I’m concerned I’d break my Nano.

I think the breakage of my jetson nano was caused by my experiments with the USB booting. Don’t use to boot it using the USB port. The code involved in this kind of booting procedure is fragile and maybe bugged. My suspect is that nvidia knows that (I read that some developers expressed some interesting argumentations where they say that there are old problems never fixed totally in some old posts) ,but I’m not sure if the developers agree with that. If this is true,the failure was caused by the code / patched created by nvidia,not by me and I could have the right to have a new board,for free. But I think that this will never happen. I’m sure they will say that the USB booting is a new and experimental feature and that I have been warned. That’s all.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.