Unknown error, please contact administrator (INTERNAL_ERROR). After fresh installation


I`m trying to install a Nucleus Workstation on a VM at our Datacenter because our Enterprise-Test-License is not valid anymore and all my Nvidia-Contacts seems to be busy with GTC, so I cannot extend the license at the moment, but I need a newer version of Nucleus than we had installed back when the license was active…

…anyway… installing a fresh Nucleus Workstation does not work anymore (tested on different machines).

  1. After installation it is impossible to login with the credentials provided at installation
  2. When creating an account from login dialog it is possible to login, but all you get is a progress ring… nothing more
  3. When connecting with Nucleus Navigator its the same, but after some time you get “Unknown error, please contact administrator (INTERNAL_ERROR).”
  4. The search service does not start… only reports “Error”, but the log for the search service is empty.

Nucleus works fine on my dev machine (but that installation is very old and was only updated since then, no fresh installation). The only difference between my workstation and the vm we have setup is that the vm has to use a proxy server to connect to the internet… but I have found nothing how to tell Nucleus to use a web proxy (for example to connect to the build-in Nvidia-Nucleus)… could this be the problem?

Can anyone help with that? A working nucleus at our Datacenter is the only missing part that prevents us to bring the result of more than one year of development to live for the first time… thank you very much


Here are the logs from all services:
logs.zip (46.7 KB)

1 Like

Hello @c.bickmeier! I’ve contacted the Enterprise team and someone will be with you shortly!

I just found the solution for (a part) of my problem…

…when installing nucleus workstation on a system that uses a web proxy to communicate with the internet it is impossible to work with that installation until you remove the link to the public nucleus from nvidia (because it cannot be accessed).

After removing that link, I have still some other problems and I think they are related to that and are a side effect of the missing internet connection while setup. For example it is still impossible to login with the credentials provided at setup. so it is impossible to connect as admin. but you can create new users through the login process.

…but the users that are created at previous installations cannot be recreated (user alread exists), but you cannot use them to login… so running nucleus workstation on systems that are behind a web proxy seems to be a little bit buggy :-)

For the window case, have you tried this

exit launcher
do above
restart launcher
start applications.

Bu you probably have done this

yes we start the launcher with proxy paramter otherwise we could not install kit.

we cannot start kit-applications through the launcher because the machine is headless… and we have our own kit app and that is started through an (own) kitagent with --no-window option.

but we pass --proxy-server to the kit process when we start it… but kit itself doesn´t seen to use that parameter (or does not do all the calls to internet ressources through the proxy).

and it is a comlete miracle to me why it would like to access that amazon-resource at all… yes there are some extensions that have such resources like the templates or material browser extension… but we do not load any of those exntensions

I got same error Unknown error, please contact administrator (INTERNAL_ERROR). and I got error with Omniverse Launcher 1.6.10 NUCLEUS tab , run the launch by MESA_GL_VERSION_OVERRIDE=4.6 ./omniverse-launcher-linux.AppImage --proxy-server=ip:port

the log is
Nucleus.log (2.2 MB).
and I want to run the RTX Lidar Tutorial 16. Publish RTX Lidar Point Cloud — Omniverse Robotics documentation, when I run ./python.sh standalone_examples/api/omni.isaac.ros_bridge/rtx_lidar.py, got this error

2022-10-26 08:44:43 [26,410ms] [Warning] [omni.client.python] Waiting for a request that has taken longer than 10000ms to complete: 
  File "standalone_examples/api/omni.isaac.ros_bridge/rtx_lidar.py", line 47, in <module>
  File "/mnt/datacenter_5/omniverse/.local/share/ov/pkg/isaac_sim-2022.1.1/exts/omni.isaac.core/omni/isaac/core/utils/nucleus.py", line 525, in get_assets_root_path
  File "/mnt/datacenter_5/omniverse/.local/share/ov/pkg/isaac_sim-2022.1.1/exts/omni.isaac.core/omni/isaac/core/utils/nucleus.py", line 189, in check_server
  File "/mnt/datacenter_5/omniverse/.local/share/ov/pkg/isaac_sim-2022.1.1/kit/extscore/omni.client/omni/client/__init__.py", line 133, in stat

2022-10-26 08:44:45 [28,842ms] [Warning] [omni.isaac.core.utils.nucleus] Could not find assets root folder
2022-10-26 08:44:45 [28,842ms] [Error] [__main__] Could not find Isaac Sim assets folder

how to fix it, looking forward to your reply.

and I try the launcher-cleanup tool launcher-cleanup@1.0.0.linux-x86_64 to cleanup launcher and reinstall nucleus service, still got same error.

I have the same problem, I can not use the A2F for metahumans since I am not able to access nucleus usd file