unknown glibc version (2.5)

I installed fedora core 6, and as a result am having problems installing the latest version (6.2.5) of PGHPF workstation. I get the following error message:

Installing software into /opt/pgi (this may take some time).
###########################################

ERROR: unknown glibc version (2.5).
ERROR: unknown glibc version (2.5).

I read a previous message from this forum explaining the need keep your operating system compatible with PGI:

https://forums.developer.nvidia.com/t/anyone-running-on-freebsd-5-3/130054/1
http://www.pgroup.com/support/install.htm#release_info

Unfortunately I read this after I update my operating system, so it looks like I am stuck with this problem.

My question is when will there be a version of PGHPF workstation that is compatible with FC6? Also, what are the repercussions of this problem? Currently, when I attempt to use ‘lmgrd.rc stop’ I get the following error message:

./lmgrd.rc stop
lmutil - Copyright © 1989-2004 by Macrovision Corporation. All rights reserved.
./lmgrd.rc: line 86: 4444 Segmentation fault $LMUTIL lmdown -q -c $LM_LICENSE_FILE

I this a result of the glibc error? When I use “lmgrd.rc start” I do not get an error, however, when I try to compile a program I get a “Failed to checkout license”.

Jim

Hi Jim,

After a new glibc version is released, It usually takes about a month or two to make any necessary changes to the compilers, libraries and header file as well as perform validation testing. Unfortunately until then, you’ll need to down grade to Fedora 5 in order to use the PGI compilers.

  • Mat

Hi,

I got the same problem when I installed PGI in Fedor Core 6,
and fixed it by modifying a little bit of “makelocalrc” file ($PGI/linux86/6.2/bin).

I simply added the followings after the line “case “$GLIBC_VERSION” in”.

2.5* )
glibc=232
LIB=$base/lib-linux86-g232
LIBLF=$LIB-lf
INC=$base/include-g23
;;

And then I excuted “makelocalrc”.

I now use pgi fortran without any problem.